HUION Kamvas Pro 22 drivers not available on DIGImend list


#21

i know why its +x not -x
chmod +x uclogic-probe-run.sh


#22

Thanks @dglt (if I have found by myself thanks to the answer of @tbg). So I have made chmod -x uclogic-probe-run.sh and ls-l gives me now -rwxr-xr-x.

But doing

sudo ./uclogic-probe-run.sh
rmmod: ERROR: Module hid_uclogic is not currently loaded
 c8 |        Params block #2: ????????
    |                          Max X: 95352
    |                          Max Y: 53645
    |                   Max pressure: 8191
    |                     Resolution: 5080
    |
 c9 |       Firmware version: HUION_M175_180925
 ca |  Internal manufacturer: HUION Animation Technology Co.,ltd
python3: can't open file 'HuionKamvasGT191LinuxDriver/kamvas.py': [Errno 2] No such file or directory

Should I reboot the computer or it wont help?


#23

there are a couple things needing change first.
remove the following line from uclogic-probe-run.sh:
nano uclogic-probe-run.sh
delete the following line
sudo rmmod hid_uclogic
dont save just yet, the following line needs a correct directory to work
DRIVER="HuionKamvasGT191LinuxDriver/kamvas.py"
you could try just “kamvas.py” but it may need the full directory wherever its located for example:
DRIVER="~/Downloads/HuionKamvasGT191LinuxDriver/kamvas.py"
ctrl-x
“y” for yes and then enter


#24

Thanks again!
Doing

I obtain rmmod: ERROR: Module hid_uclogic is not currently loaded

Should I do it in a special directory? I have done it in the directory called “HuionKamvasGT220v2LinuxDriver”.

edit: as I wrote, I am “newbie” and I read too quickly. So I have tried to make sudo rmmod hid_uclogic within the terminal instead of deleting it within the script. Now I have removed this line within the script. In this script, I have also written the accurate position of the driver /home/~/Documents/etc.etc.

Afterwards, I have done:

sudo ./uclogic-probe-run.sh
 c8 |        Params block #2: ????????
    |                          Max X: 95352
    |                          Max Y: 53645
    |                   Max pressure: 8191
    |                     Resolution: 5080
    |
 c9 |       Firmware version: HUION_M175_180925
 ca |  Internal manufacturer: HUION Animation Technology Co.,ltd
Huion Kamvas GT220 driver should now be running

Similarly to the moment durinh which, I had previously made

sudo ./start-driver.sh
 c8 |        Params block #2: ????????
    |                          Max X: 95352
    |                          Max Y: 53645
    |                   Max pressure: 8191
    |                     Resolution: 5080
    |
 c9 |       Firmware version: HUION_M175_180925
 ca |  Internal manufacturer: HUION Animation Technology Co.,ltd
grabbed interface %d 0
grabbed interface %d 1
Huion Kamvas GT220 driver should now be running

I can see at the end of these two terminal windows that there is a white rectangle at the beginning of a line, instead of for example [nameexample@computername HuionKamvasGT220v2LinuxDriver]$ that would allow me to write a new command line (that is why I have opened a second terminal windows to continue the installation). I can write letters at the place of the white rectangle but I do not know if it means something that I do not obtain the line with for example [nameexample@computername HuionKamvasGT220v2LinuxDriver]$


#25

the script as it is assumes you have the module “hid_uclogic” loaded, which from the looks of you dont so you can remove that whole line from uclogic-probe-run.sh . i edit that post to clarify exactly.

yes, but what directory does that directory reside in? /home? ~/Downloads?


#26

Thanks for the thousand time @dglt. I have read too quickly your answer once again and thought that you want my results in the edition of post #24. So you can find there at this place


#27

does the tablet/pen now work?


#28

you may want to double check the specs of your particular tablet and make sure those are the right values.


#31

No it does not work. It is like in the beginning:

At https://www.huion.com/pen_display/Kamvas_Pro_22.html I can read 8192 Levels. Does the
Max pressure = the Levels number or is it normal that there is on more Level Number?

I do not find Max X and Max Y by now.

I’ll reboot the computer and try once again to make the tablet work. If not, I ll change this MaxPressure number.

Rebooting does not help.
edit : it helps just to prove that the two aforementioned (in the edition of my post #24) processes were still running and I marked it by clothing these terminal windows.

Where can I modify by the way the max pressure number?
edit: @bogdancovaciu @tbg may I ask you if you also have an idea? I hope that you are not in a delirium tremens phase… :wink:


#32

kamvas.py but i dont think thats your problem.
i do however see @tbg is typing away and he usually chimes in with great advice or to yell at people. hmmm… :popcorn:


#33

Certainly not, that usually doesn’r start till I get much closer to Xmas festivities. :wink:

Sorry I don’t think I’ll be of much assistance, as I’ve never even used a tablet. Bogdan is the one with a wealth of knowledge in that area. You ll just have wait and see if he pops back around.


#34

Thanks @dglt. I have modified this number in kanvas.py but doing afterwards sudo ./uclogic-probe-run.shandsudo ./start-driver.sh` the max pressure number displayed in the terminal is still: 8191… (instead of 8192).
Furthermore the two processes never ends and they make the ventilator of my computer make a lot of noise… Is there something not working when I am typing these two commands?

In addition, according to the specs of this pen display, is there a possibility to calculate if Max X and Max Y equal respectively 95352 and 53645.

Dimension 589 x 344mm
Active Area 476.64 x 268.11mm

Thanks @tbg too!


#35

If this is the command you are running below:

sudo ./uclogic-probe-run.sh

Then here are some examples of ways you can prevent the script from running continuously in your terminal window:

sudo ./uclogic-probe-run.sh > /dev/null 2>&1 & disown; sleep 2; exit

sudo ./uclogic-probe-run.sh; sleep 2 & exit

sudo ./uclogic-probe-run.sh &

#36

this i do not know, i believe the name of your model is gt-221 (did not know this till now), the driver was for gt-220
there is a driver here but its for gt-119 (written by/for arch user)

also try running those 2 scripts in reverse order, i would think uclogic-probe would come before the start-driver but who knows. im also looking around at the same model under other names since its made by uc-logic and rebranded in a few names besides huion


#37

Thanks, I read also this information there.

Which 2 scripts? The uclogic-probe-run.sh and start-driver.sh? Or new drivers for gt221?

Is it meaningful to try with the GT191-one since it seems similar with the the gt221?

Once again, my computer’s ventilator is super noisy despite the fact that I have not made the aforementioned sudo for running the uclogic-probe-run.sh and start-driver.sh, and despite the fact that a few of software are running… My computer is quite new and has just made this kind of noise once as I had a problem…

edit : I have changed the order and try to run uclogic-probe-run.sh before start-driver.sh and start-driver.sh before uclogic-probe-run.sh wihtout any success…


#38

I had to do some reading as i don’t know anything about this model and how the digimend drivers work.
From what in understand you should have the pen working, as they use the same technology for the stylus (as they switched to battery free Pens - same as wacom) on Huion GT-220 V2 and Huion KAMVAS PRO 22 - both models use the same display when comes to ratio and active area size. The only difference i see is the buttons.
Same goes for Huion KAMVAS GT-191 - but to me, the driver made by Tobias seems more efficient and complete, but yet, to be usable for Huion KAMVAS PRO 22 would need the buttons layout. David Revoy wrote a how to some time ago, but because i tested more wacom tablets, i never really got into other models.

Before, having the screen space mapped correctly was an issue also for this tablet, but not anymore.

And all this settings i can get only in KDE Plasma.
Probably the Huion would work with the wacom driver too, or make use of it. Even if on linux the libwacom should work by itself (as in Gnome does recognizes the tablet) it still needs the xf86-input-wacom for the pen … And personally i still think is a mess, but not as bad as was before.

This rant will not help much, but maybe leads to try a different approach.


#39

theres something you might try, it looks like there is only a few differences in the kamvas.py between the gt-191 and gt-220 and i keep finding the 191 and 220 in the same boat without a paddle but 191 driver reportedly works according to krita (for the 191). they are all very similar.
you might try replacing your kamvas.py for the one here and trying again, worst case scenario you lose 2 minutes of your life.
@bogdan seems better equipped to determine if you should or not, i have zero tablet experience.

also: you may of already seen this on the Krita FAQ page but just in case:

What if your tablet is not recognized by Krita?
Linux
We would like to see the full output of the following commands:

lsmod
xinput
xinput list-props (id can be fetched from the item 2)
Get the log of the tablet events (if applicable):
Open a console application (e.g. Konsole on KDE)
Set the amount of scrollback to ‘unlimited’ (for Konsole: Settings ‣ Edit Current Profile ‣ Scrolling ‣ Unlimited Scrollback)
Start Krita by typing ‘krita’ and create any document
Press Ctrl + Shift + T, you will see a message box telling the logging has started
Try to reproduce your problem
The console is now filled with the log. Attach it to a bug report
Attach all this data to a bug report using public paste services like paste.kde.org


#40

It doesn’t matter my experience with tablets. Your understanding of how they work, or how drivers work lead this topic to the point to get some positive results. Nice work :wink:
I’m still reading how they work, but have no idea what can be done.

I always start with:
xinput --list
without the pen close and then with the pen close to the display.
One thing to mention, with the kernels above 4.14 there is a simultaneous event that connects and disconnects the tablet. I always have to turn it off and on to work. I reported that issue to the one responsible with that module in the kernel but so far was no reply. If that happens now in this case, all the scripts will fails somehow … so, make sure @Killi that you turn off and on again the tablet, then run the scripts again, and then test the Stylus.


#41

Thanks @bogdancovaciu et @dglt for your long messages. I am now quite a bit lost with all these information. I do not know where I should begin and I want I should make with the two scripts we have begun with…

edit

For that, should I download xorg-xinput in pamac?


#42

Yes, once you install it, reboot then turn off and on the tablet and do what @dglt mentioned from Krita, the commands he posted. xinput and xinput --list are the same thing :slight_smile: but the rest will show more information.

Don’t be let all this drag you down. It will be solved at one point.
I’ll have a look in the morning at all was posted so far, with fresh eyes.