HUION Kamvas Pro 22 drivers not available on DIGImend list


#191

Is good that you payed attention and you are learning :wink:


#192

I am learning a lot thanks all of you three @bogdancovaciu, @dglt and @tbg!

Are these other lines not important in this “code” :

Encoding=UTF-8
Version=0.9.4
...
OnlyShowIn=XFCE;
StartupNotify=false

Can I add them to

For information, when desktop entry or .desktop file as no Name=something, it is not anymore listed in the xfce-settings-manager.

Should we add apostrophes? I read here:

~/src/sandbox$ xfce4-terminal -e 'sudo ./test.sh' 

If yes, should it be


TryExec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh' &
Exec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh' &

or with ampersand within the apostrophes?


TryExec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &'
Exec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &'

#193

I do not think you should need the apostrophes. Either way, we can not predict what will work on your system. You just need to experiment until you find the right working combination.

You need to do the work. It is your system, we can not test stuff out on your system, you must do that.


#194

Is there a life without Manjaro?
Yes,
but it’s pointless. :slight_smile: :wink:


#195

With that it seems to be really better! This terminal windows opens:
Capture%20d%E2%80%99%C3%A9cran_2018-12-19_22-40-53

edit: I will try with the ampersand outside of the apostrophes.


#196

thats good, the rmmod error is probably from running the script more than once since the first time already issued the rrmod command


#197

With the ampersand outside of the apostrophes, no terminal windows asks me my password apparently so it is graphically not so convincing as with the ampersand in the apostrophes but I have no really idea of the syntax…


#198

Please do not post pictures of text outputs on technical help threads. It is hard to read sometimes and text can’t be copied from a pic.

From the looks of the error message your driver wasn’t loaded so it errored at the rmmod attempt.


#199

so bottom line, does the script run at boot properly with or without ampersand inside? does it run properly without asking password?

from the image you just posted, it looks like its runnning properly, the rmmod only threw and error because you already ran the script previously on the same boot, the hid_uclogic module can only be unloaded once, and regardless it looks like the rest of the script ran through. yes?


#200

Exactly, I have rebooted my computer with huion.desktop in ~/.config/autostart written with the ampersands within the apostrophes and after the boot, this error message does not appear and it seems to work. Nevertheless, after that the xinput --list does not contain the pen and I cannot draw with the pen (also by sleeping/awaking the computer. I think we are not far once again!! Thanks once again for your patience!


#201

You need to check the paths inside all your scripts to see that they contain the full paths. @bogdancovaciu already mentioned this quite some time ago.


#202

easy enough to figure that out , if you run sudo rmmod hid_uclogic and it throws back an error than the script ran. if it throws no error, no script was run.

this is a very valid suggestion. if you double click that .desktop file, does the script run properly and pen start working or not? if not then the directories inside are incorrect


#203

This depends on the method used to launch the script. If the script executes properly in the background there will be no visible indication the script has even run.


#204

But must it be a problem of the full paths inside the script? Indeed when I boot the computer, the huion.desktop seems to work more or less since it appears automatically asking me my password and then seems to launch more or less the script-driver.sh (I have indeed the same information in the terminal as the one we can see in my post #146 without the error message line and as you can see there you find information regarding the graphic pad…


#205

Yes, but Bogdan already tried to explain to you when your launching the script from the terminal in your home directory the path is already established. You are now launching the script from another location, so you need to make sure any path within your scripts contains the full path.


#206

Thanks but I unfortunately do not see where is the problem in the paths that all seem to be full. Furthermore, I have the impression that huion.desktop can now redirect to start-driver.sh since I can see all these information after the boot and since what appear in the terminal is the same as what appear when I do sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh.

The code of huion.desktop is now:

[Desktop Entry]
Type=Application

Name=Huion
TryExec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &'
Exec=xfce4-terminal -e 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &'
Terminal=true
Hidden=false

Should the TryExec line stay?
Should Terminal=false?

The start-driver.sh is currently:

#!/usr/bin/env bash
# Adjust this as needed
DRIVER="/home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/kamvas.py"

T="256c:006e"
BUS=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\1|g')
DEV=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\2|g')

sudo rmmod hid_uclogic
sudo modprobe uinput
sudo /usr/local/bin/uclogic-probe $BUS $DEV | /usr/local/bin/uclogic-decode
sudo python3 $DRIVER > /dev/null 2>&1 & disown; sleep 2; exit

#207

Hello @SGS, as an user of XFCE do you have an idea (apparently, if I correctly understand) the apostrophes were needed in XFCE are not in KDE. There are maybe other differences that you could know. Sorry for bothering you and thanks in advance.


#208

It was apparently because huion.desktop ran several times and had already moved hid_uclogic.


#209

if you see that the .desktop file is properly running the script try a short sleep before the script runs at boot, i think you would modify like this
sleep 10 && 'sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &'
not 100% on that though


#210

it was also my intuition that I ran too quickly. I will try! Thanks for the code!