HUION Kamvas Pro 22 drivers not available on DIGImend list


#1

Hi everyone,

I would like to use the graphic tablet or “pen display” Huion Kamvas Pro 22 with my 4.19.6-1-MANJARO x86_6 kernel. When I connect it, its screen displays what we can see on my screen but does not recognize the pen… Yet, this “pen display” does not seem to be listed in DIGImend list.
Nevertheless, @not-surt wrote on GitHub that it worked perfectly.
On reddit cited by @not-surt on this page , I have found this link, downloaded it and red the instructions and saw that is made for windows (the other file available in this .rar archive is a .exe file…)
Has someone an idea of what I could do to use my “pen display”?
Thank you in advance.


Graphics tablet resolution doesn't match screen
Wacom 16 screen brightness/contrast can be configured?
WiFi and soft lockup issues in Acer Nitro 5
How to install nvidia driver for secondary GPU on laptop
Would Ugee 2150 and a Wacom tablet conflict?
#2

from what ive read the HUION kamvas is just a rebranded uc-logic .
this if for the huion gt220v2 but it might help, uclogic-tools are in aur

may have to edit the line 5 in start-driver.sh to match your tablet id, you can find it with:
lsusb | grep "$T"
and edit
line 5: T=“256c:006e”
to match yours


#3

I don’t have experience with that model. You could try to use this wiki
https://wiki.manjaro.org/index.php?title=Wacom_Tablet_And_Pen

A note about it: Only on KDE Plasma, Gnome and Cinnamon you will be able to use a GUI to set up the buttons, map the tablet area and set up the pen buttons and how firm the tip is, when using the wacom driver …
My suggestion, whatever test you made, take note to be able to revert back and try more things. IMO the pen should work without much fuss, the problem would be the buttons and mapping …


#4

Thank you very much for your answer @dglt . If I compare the AUR version and the one on GitHub, I see that the AUR is 4-1 last modified in 2016 and the one in github is 5.1 released two weeks ago. Should I nevertheless downloaded in AUR through Pamac? If not, how could I download the new version available on Github and install it?
Thanks again!
Have a nice day!


#5

Thank you for your answer @bogdancovaciu. Since I am using XFCE, I will try gsdwacom4xfce in a second time.


#6

download an extract to its own directory:
https://github.com/DIGImend/uclogic-tools/releases/download/v5/uclogic-tools-5.tar.gz
then:
open a terminal in that directory and
./configure && make
sudo make install

or you could just try using the ones in aur. maybe try the arch wiki @bogdan suggested first and if it doesnt work, do :point_up:


#7

Don’t bother with that. Since Gnome changed a lot of things is not working anymore, and you will chase green horses for nothing :wink:


#8

Thanks again @dglt and @bogdancovaciu. I have made what @dglt told me and it seems to have worked.

Now, I will try to install https://github.com/kyledayton/HuionKamvasGT220v2LinuxDriver but it seems to be not so easy…

For information, there is no need to edit the line 5 since I have found thanks @dglt using lsusb | grep "$T" that T=256c:006e also for my Huion Kamvas Pro 22.


#9

im glad it worked out.

i dont use a wacom tablet but i can try to help you through the install. what seems to be the difficult part?


#10

Euh…, as you see, I am a “newbie” and it is difficult to me to understand something on the readme of https://github.com/kyledayton/HuionKamvasGT220v2LinuxDriver and on the script https://github.com/benthor/HuionKamvasGT191LinuxDriver/issues/1#issuecomment-351207116 cited in the beginning of this readme… So now I am quite lost and do not know how to begin…


#11

you already installed ulogic-tools, now make sure you have the other dependencies.
sudo pacman -S python-pyusb python-evdev xf86-input-evdev git
sudo nano /etc/X11/xorg.conf
copy/paste this (xorg.conf will be created if it does not exit already) and then ctrl-x and select yes to save.

Section "InputClass"
	Identifier "evdev tablet catchall"
	MatchIsTablet "on"
	MatchDevicePath "/dev/input/event*"
	Driver "evdev"
EndSection

edit: i added “git” to the list of packages to install with pacman above

open a terminal in a directory you decide then:
git clone https://github.com/kyledayton/HuionKamvasGT220v2LinuxDriver
cd HuionKamvasGT220v2LinuxDriver
sudo ./start-driver.sh


#12

Please expound on this @bogdancovaciu. Where are these green horses found that you speak of. Is it possible they inhabit the same territories as the pink elephants. :smile:


#13

i believe the pink elephants have moved on to the "windoze territory’


#14

Perhaps @bogdancovaciu can draw a landscape of them both frolicking together in their natural habitat. I think that would go nicely with the classic picture of “dogs playing pool”. :smile:


#15

Green horses like pink elephants are rare like red herrings … All got eaten by the invisible man/woman :stuck_out_tongue:


#16

Thanks once again @dglt !! Since /etc/X11/xorg.conf does not exist, I am creating a new file. In the terminal in nano, they ask me in which format I want to write this “file”. Format DOS, Mac, Add (at the End) or Add (at the Beginning) are proposed. What do you think? Sorry for all these dummies questions… I am learning, I am learning…


#17

i knew pink elephants were real

edit: dont want to post unrelated vids in this category. must refrain myself :smirk:


#18

sudo nano /etc/X11/xorg.conf
add contents then:
ctrl-x
“y” for yes
and if you just hit enter it will save as xorg.conf , you dont need to specify msdos or anything else.

also, as you mentioned before about the issue cited at the beginning, it says uclogic-probe needs to be run at least once every boot, for now you can create uclogic-probe-run.sh (name it what you want) in the same directory as the driver.
nano ~/Downloads/HuionKamvasGT220v2LinuxDriver/uclogic-probe-run.sh <—modify to match your directory the “~/” points to your home directory
copy/paste the following:

#!/usr/bin/env bash
# Adjust this as needed
DRIVER="HuionKamvasGT191LinuxDriver/kamvas.py"

T="256c:006e"
BUS=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\1|g')
DEV=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\2|g')

sudo rmmod hid_uclogic
sudo modprobe uinput
sudo uclogic-probe $BUS $DEV | uclogic-decode
sleep 3 # wait until device is released again
sudo python3 $DRIVER

ctrl-x
“y” for yes and hit enter and then make it executable:
chmod +x uclogic-probe-run.sh
sudo ./uclogic-probe-run.sh
@tbg , your good with scripts and such, would uclogic-probe-run.sh need to be made executable with sudo since it will require sudo to run or is chmod at user level ok?


#19

Most scrips should only require a chmod +x to make them executable. If the script requires root permission the user should receive a prompt for the sudo password when the script is executed.


#20

Thanks once again @dglt. I have made

but then making ls -l, I see that this file is not executable -rw-r--r-- 1.

Thats is probably (I suppose) why doing sudo ./uclogic-probe-run.sh, it answers sudo: ./uclogic-probe-run.sh : commande introuvable