HUION drawing tablet has mysteriously stopped working


#1

Hello, I hope this is the proper place to look for help with this issue. I have searched around the web and this forum and found nothing so far that has helped.

My problem is this: My HUION H610 drawing tablet has stopped working, by which I mean that the buttons (which were working properly the last time I used it on 27-10-18) no longer register any input to Krita or any other program. Unfortunately I cannot test if the pen input is working because the pen is out of battery and refusing to charge (this is the second pen that has spontaneously died since getting the tablet earlier this year), but I have plugged the tablet into my sister’s Windows 10 PC and the buttons on the tablet work properly there, so I don’t believe that it is a hardware issue with the tablet itself.

I am running Manjaro KDE Stable, with the 4.19.4-1 kernel.

Since I last used the tablet I have used yay to update ‘digimend-kernel-drivers-dkms-git’ to the latest version, but did not test the tablet before / after this upgrade, so I can’t be certain that’s what stopped it working, though the update appeared to be successful. As far as I know, nothing else specific has changed about my setup except anything that might have changed via pacman updates in the last month. All my other hardware (USB Soundcard, Logitech mouse, Xbox wired controller) are all still working as well as ever and I have noticed no other problems whatsoever with my system.

I have noticed that in Settings under Input Devices, ‘HUION PenTablet Pad (/dev/input/js0)’ is listed in the Joystick section, and ‘HUION PenTablet P [006E]’ is displayed in the Graphic Tablet section (kcm-wacomtablet package). As far as I can remember, the tablet displayed in neither of these sections back when I first set it up 2 or 3 months ago and it worked just fine.

To get it working back then I installed ‘digimend-kernel-drivers-dkms-git’ from the AUR, created ‘52-tablet.conf’ in /usr/share/X11/xorg.conf.d/ with the following content -

Section “InputClass”
Identifier “Huion on wacom”
#MatchIsTablet “on”
MatchProduct “HUION”
MatchDevicePath “/dev/input/event*”
Driver “wacom”
EndSection

and I set up an SH file to run at startup containing a number of commands like this: ‘xsetwacom --set ‘HUION PenTablet Pad pad’ Button 2 “key e”’ in order to bind the buttons correctly.

This worked flawlessly. All buttons were working as expected and the pen and pressure sensitivity was perfect, and this was the case up until my last use of it on the 27th of October. However, today I tried to use the pad for the first time since then and none of the buttons are working, and I am unable to test the pen as it seems to have died and is not charging (its charging plug has been dodgy pretty much since the first charge). The light on the tablet lights up when I press the buttons as it always does but no input seems to register in any of the programs I have tried. I have been able to connect the tablet to a Windows 10 VM running on my system using USB passthrough, and it does seem to recognise the tablet and be registering some kind of input from the it, though the VM does not have an internet connection or the HUION drivers installed to test it properly.

To try and fix the problem I have tried booting with an earlier kernel (4.14), tried plugging it in to different USB ports, reinstalled the digimend drivers and the kcm-wacomtablet package and used Downgrade to roll back the digimend drivers to the previous version, all to no avail (I am currently running the older driver having not re-upgraded it). I also followed these instructions - https://forum.level1techs.com/t/fix-for-linux-wacom-users-tablet-shows-up-as-joystick/115932 - incase the fact that the tablet seemed to be showing up as a joystick in the system preferences was part of the problem but that didn’t help, though that file only seems to list the H610 Pro, so it may not be helping because of that.

‘xinput -list’ shows the tablet and pad under Virtual core pointer the same as it always did, ‘xsetwacom list devices’ returns the pen and pad as I think would be expected and ‘uclogic-probe 5 2 | uclogic-decode’ returns the following:

Manufacturer: HUION???
Product: PenTablet?
Max X: 40000
Max Y: 25000
Max pressure: 2047
Resolution: 4000
Internal model: HA60???
Buttons status: HK On

All of which seems to suggest to me that the tablet is connected and recognised by the system, yet the buttons still do not register in any program, despite trying to set them both using my usual xsetwacom commands and with the GUI in the system settings (which I never used before).

Sorry for the long post, I tried to include all the detail I thought would be relevant. I am still pretty new to Linux (first tried out Ubuntu in February) and switched to Manjaro two or three months ago, so any help would be greatly appreciated as I haven’t a clue how to go about sorting this! Thanks!


#2

Have you tried booting with different kernels other than 4.14 and whatever you are currently running?

regards


#3

Thank you for replying,

Yes, I have just tried 4.18.20 as well and that hasn’t helped.


#4

Create the /etc/X11/xorg.conf.d/11-evdev.conf file with this content in it:

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

reboot and let me know if the tablet came back to initial functionality


#5

I don’t know anything about tablets or configuring them. (@bogdancovaciu may?) But I do wonder why that line above is remarked out?

Anyway, someone that does know these things should be along soon.

regards


#6

Hi, thanks for replying.

I have done that and rebooted but still no input seems to be registered from the tablet’s buttons. Unfortunately I cannot test if the pointer works as the pen is dead.


#7

Ok, no worries. What i mentioned i have to do to get my Cintiq22HD working. Is a libinput vs xf86-input-xxxxx and other drivers …
Did you renamed digimend.conf to depmod.conf as mentioned here ?
Is seems the AUR package has not that commit to it… or does it ?


#8

I did try that just before I rolled back the drivers (I noticed someone had commented about it on the AUR page when I was trying to figure out how to roll them back). It didn’t seem to make any difference after a reboot, and I also presume that the file was there in it’s original state the whole time that I was using the tablet when it was working anyway. Re-installing the older version of the driver re-created the digimend.conf file, so now I have both digimend.conf and depmod.conf in that folder.


#9

One has to go … removed … keep the depmod.conf one but compare the content of them before …
also, what is the output of
lsusb
You mentioned that you created the 52-tablet.conf but i see you did not make use of
MatchUSBID "<VID>:<PID>" as suggested on their github


#10

Ok, got rid of digimend.conf, kept depmod.conf, both had identical contents.

lsusb returns:

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 005: ID 046d:c539 Logitech, Inc.
Bus 005 Device 004: ID 1235:8016 Focusrite-Novation Focusrite Scarlett 2i2
Bus 005 Device 003: ID 045e:028e Microsoft Corp. Xbox360 Controller
Bus 005 Device 002: ID 256c:006e
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0748 Genesys Logic, Inc. All-in-One Cardreader
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I believe the tablet is "Bus 005 Device 002: ID 256c:006e "

I have read down the readme.md on their github and it seems that the 50-tablet.conf they suggest creating differs from what I have, I will try following their instructions and seeing if that makes a difference. Also they say to name it 50-tablet.conf rather than 52-tablet.conf as I have, would that make a difference? If I recall correctly I created that file shortly after I first started using Linux earlier this year and have just kept it backed up and copied it across each time I reinstalled a distro. I think I just copied its contents from AskUbuntu or somewhere similar.


#11

Ok, I’ve moved 52-tablet.conf from where it was in /usr/share/X11/xorg.conf.d/ to my desktop, and i have followed the instructions on digimend’s github to create 50-tablet.conf in /etc/X11/xorg.conf.d/ with the following content:

Section “InputClass”
Identifier “Tablet”
Driver “wacom”
MatchDevicePath “/dev/input/event*”
MatchUSBID “256c:006e”
EndSection

Then rebooted. I manually ran the xsetwacom commands to map the buttons too, just to be sure they had been set, but still no difference, nothing registering from any of the buttons.

The tablet is still appearing in Settings in Input Devices under both Joystick and Graphic Tablet.

I don’t know if it would be worth trying to put the new conf file into /usr/share/X11/xorg.conf.d/, since that was where I had 52-tablet.conf before? My very limited knowledge of Linux leaves me with no idea if that would make any difference compared to leaving it in /etc/X11/xorg.conf.d/.

I’m wondering if a fresh install of Manjaro is in order, at least then I can be absolutely sure I haven’t inadvertently installed or changed anything that might have broken it, and I can work through the necessary steps to get the drivers going from scratch. (I could finally reclaim the space Windows used to take up on my drive at the same time…)


#12

And you applied the fix you mentioned?

Try a VirtualBox install (compare the two). See what changed at the update you made.
Any particularity while running from terminal:
sudo modprobe -r hid-kye hid-uclogic hid-polostar hid-viewsonic


#13

Yes, that’s with that fix applied.

I’ll try setting it up in a VM and see if that sheds any light on it with that command! Thanks!


#14

Try to get it working without the digimend procedure … Not sure what model you have without the
xinput --list
but many of the Huion tablets where added to the input-wacom/xf86-input-wacom/libwacom in order to work on linux and in special with KCM-Wacomtablet … and if one of those additions came to the update you made, the result would be a sort of duplicate “/dev/input/event*” readings, hence the duplicate entry in both Graphic Tablet and Joystick in system settings, but that shouldn’t render your tablet unusable, because my Cintiq works even if is present in the Joystick entry too …


#15

Right, so I haven’t done a great deal of messing with the virtual machines yet but…

I have created a fresh Manjaro install in VirtualBox and fully updated it, though still on 4.14 kernel. After that I passed through the USB of the tablet and saw that it was listed in ‘lsusb’ and in ‘xinput list’, but the pad was under the keyboard section for the xinput list, and it was not displayed in the system Settings under Input Devices. No sign of it working yet.

Then I installed kcm-wacomtablet and rebooted and again the same results, and nothing displaying in ‘xsetwacom list devices’.

Then I installed the digimend drivers and set up the 50-tablet.conf as per their instructions and rebooted and found that it now displayed correctly under pointer in ‘xinput list’ and also appeared correctly in ‘xsetwacom list devices’, so I used the ‘xsetwacom --set’ command to bind its buttons and tested it again and this time it worked!

In its working state it is still not showing up in system settings under either Joystick or Graphic Tablet, which I’m fairly sure was also the case when it was still working on my actual machine.

Running the modprobe command you suggested and rebooting seemed to completely disable the tablet’s usb input and the tablet vanished from lsusb and xinput. After reversing this though and rebooting it worked the same as before. It didn’t give me any errors when I ran the command, though it only let me do hid-kye and hid-uclogic, the other two were not present. I have also just updated the kernel in the VM to the latest 4.19 which is what I am running on my actual machine and it is still working properly.

I guess next I’ll try again, but this time get the tablet working before updating, and see if it survives the updates.


#16

This problem seems to have been resolved for the time being. The tablet is still appearing in Joystick and in Graphic Tablet in System Settings which I still don’t understand, but after re-upgrading the digimend drivers using Yay and selecting CleanBuild when installing, the buttons on the tablet once again work. I am still unsure what exactly caused this problem in the first place, but the only thing I can think of is that the first time I installed the digimend drivers it was using Octopi with Yaourt, and when I later upgraded them for the first time it was using Yay, so perhaps that caused a problem, and I can only assume that something about reverting the drivers using Downgrade and then re-updating using Yay and selecting CleanBuild fixed it, since I had not touched my computer otherwise in over a week.

Thank you @bogdancovaciu for all the help you gave me with this problem.


#17

it’s terrible , just contact the huion tech support , I’ve been running Manjaro KDE Stable for a while now with my 11.6" IPS XP-Pen Artist 12 Pen Display Drawing Tablet and love it , I can really recommend the xp-pen Artist 12 . Used it for about 200 hours and had 0 problems.


#18

so i am here just to post this so that the internet can have THIS bit of info… i will not be on for update after this so im going to get as much info as i can.

(short story) i have a huion graphic pen tablet model G10T. there was lag from time to time when my gf would try to draw but i could not track down the problem UNTIL JUST NOW! it was not the drivers for the tablet (my first thought) BUT it ONLY happens when we have NETFLIX up! @.@ idk why… but that did it. with Netflix not running it wound work just fine.

(long story with all kinds of info)

(to describe the problem) when she would get the pin and place it on the tablet the first stroke was lagging behind and would catch up after a sec and was really hard to draw.

(re-doing the drivers for huion tablet is a WAIST OF TIME!) i have re installed the drivers for this tablet over 20 times on 3 different computers. never could figure it out as to why is was ok then not for time to time. even having the tablet plugged in and going straight to a usb 3.0 it was still doing this (wireless tablet.)

(computer specs)
intel i7 8700k
32 gigs of ddr4 ram
gtx 1080 with the drivers at 418.91
as far as the tablet the drivers i have are 8.33.30.0. (thats what device manager said it was.)
web browser was google chrome.

thats all i can think of off the tip of my head but I KNOW FOR A FACT THIS WAS A FIX FOR ME. it was 100% repeatable and i still dont know why it was going this… :(:thinking: buti just wanted to get this into on the interwebs :stuck_out_tongue: i hope this helped you if not sorry it was a waist of time.

have a good one!