Huge ram and CPU consumption... tracker-miner-f

Hello
I have a problem with tracker-miner. I tried some methods to disable tracker but I failed… What can I do? I would like to limit it or complete disable.

You could uninstall the package. However according to the Archwiki the following packages depend on it:

There are options in the dconf application for tracker under
/ org / freedesktop / tracker /

Be cautious when editing values,

Documentation is here:
https://wiki.gnome.org/Projects/Tracker/Documentation/Configuration

There is a script in the community repository that might help: disable-tracker

I tried dconf but still tracker takes ~25% of ram

What do you use to determine that?

Sorry but I don’t understand… I tried to change some values in dconf…

What do you have installed that depends on tracker and tracker-miners? That should tell us what it’s trying to index. As @Graham pointed out, there’s not much left the requires them. tracker3 has mostly replaced it.

Please post the output of the following:

pacman -Qi tracker tracker-miners | grep "Required By" 

~ >>> pacman -Qi tracker tracker-miners | grep “Required By”

~ >>> [1]

Empty…

image

sudo pacman -Rns tracker tracker-miners
1 Like

sudo pacman -Rns tracker tracker-miners
I did it. Not helped

Is tracker still running? Check with:

ps aux | grep tracker

If so…

killall tracker

Then run the first command again to make sure it’s no longer running.

biuro@manjaro Linux 5.9.16-1-MANJARO x86_64 20.2.1 Nibia
~ >>> ps aux | grep tracker

biuro 2448 18.4 16.3 2976732 1328884 ? SNsl 19:52 4:36 /usr/lib/tracker-miner-fs-3
biuro 10056 17.7 0.6 1182924 51820 ? RNsl 20:06 2:04 /usr/lib/tracker-extract-3
biuro 32146 0.0 0.0 199024 2368 pts/0 S+ 20:18 0:00 grep tracker
~ >>> Conky shows tracker-miner-f eats ~20% of ram and some % of CPU

Do the same thing as above but replace tracker with tracker-miner-fs.

Leave tracker-miner-fs-3 alone.

Something is realy wrong. Tracker-extract and tracker-miner-f still eats my CPU and ram and my PC is unusable. Freezes all the time. I tried reinstall Manjaro but still the same issues. Hard disk is 2 months old and test shows it is OK. I thing than some update did that issue. Do you have any ideas how to fix it?

If tracker-miners is no longer installed reboot and they won’t be running. Removing packages does not affect files still in memory.

1 Like

I installed OS again, changed disk to SSD and now all works great. Maybe it was not tracker issue. Maybe something else did that issues. Thanks for your help :slight_smile: