Huawei Laptop Screen Doesn't Turn On

So I’ve had Manjaro Linux installed on my Huawei Matebook D14 since last December and it’s been working fine, but lately (starting in September) the laptop will not boot properly. When I turn it on, the screen flashes the Huawei logo twice and then the screen just goes black. Occasionally it progresses to an error message that reads:

[FAILED] Failed to start Load/Save mtness of backlight:amdgpu_b10.

(I think the word says mtness; it’s hard to tell what the first character is because of the font)
After the error message, the screen goes black as usual.

One time, I managed to get to the display manager and I typed in my password. However, after hitting enter, my screen froze and eventually the screen turned off as well.

The laptop is still on when the screen turns off because I can hear the fan and see the backlight behind the keys. I assume that I installed some update to the graphics drivers that broke things, but I can’t update the drivers again because I can’t use the laptop as it currently is.

The GPU on the laptop is the Radeon Vega 8, and I believe I am using the default drivers that come with Manjaro.

Any suggestions?

Have you tried adding acpi_backlight=vendor to the boot parameters?



Then sudo update-grub and reboot

Please see also:

I tried adding that to the boot parameters and it didn’t change anything. Masking the service removed the error message but my screen still turns off as it did before, just without the error message beforehand

Well, I tried reinstalling Manjaro to fix the issue, and now the laptop fails to boot into either the SSD or the live iso lol. I also tried burning the iso again in case the USB stick was faulty.

I’m at a bit of a loss as to how I’d even go about fixing this issue now, considering I can’t even boot into a live iso. Doubt I could even reinstall Windows on the laptop considering it can’t boot into either the (evidently failed) Manjaro install or the live iso.

Somehow Secure Boot got turned back on during the reinstall lol. I didn’t notice this; disabled secure boot and it boots just fine now. I’ll have to get all my files back on, but yeah, I don’t know of any solution to this issue other than just doing a clean Manjaro reinstall.

Before reinstalling, I did try to do a full system update using chroot in the live iso, but it didn’t change anything unfortunately, so reinstalling did seem to be the easiest solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.