Hplip-plugin 'invalid signature


#1

After updating today (2017-10-26) my HP printer will not work. Hplip-plugin and hplip-plugin-manjaro do nothing. Except tell me their is a invalid signature while attempting to install or update this this . Any fixes soon?

Rich :slight_smile:


HP printer driver corrupted
#2

Have you tried this?


#3

==> Building and installing package
==> Making package: hplip-plugin 3.17.9-1 (Thu Oct 26 10:24:43 MDT 2017)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading hplip-3.17.9-plugin.run…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- 0:00:05 --:–:-- 0
100 35135 100 35135 0 0 5855 0 0:00:06 0:00:06 --:–:-- 146k
==> Validating source files with md5sums…
hplip-3.17.9-plugin.run … FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build hplip-plugin.
==> Restart building hplip-plugin ? [y/N]
I ran the commands to update signatures and here is still the issue. . .

Rich :slight_smile:


#4

Ah, ok, I see, it’s a different signature error than the one I suggested the solution to.


#5

You’re downloading an AUR package so the place to check would be the AUR package page: https://aur.archlinux.org/packages/hplip-plugin


#6

This guy want to set up his printer.
Why are the plugins not in manjaro repo?


#7

He can use archlinuxcn binary repository for hplip-plugin adding into /etc/pacman.conf


[archlinuxcn]
Server = https://cdn.repo.archlinuxcn.org/$arch


sudo pacman -Syy && sudo pacman -S archlinuxcn-keyring


#8

Because most HP printer don’t need them. The normal hplib is in the extra repository. Also the plugins for hplip are binary files with a proprietary license.

Also I would not recommend to add a extra repository for that packages. Specially if you can’t read the website of the main domain. https://archlinuxcn.org


#9

This domain just contains information from archlinux.org in Chinese. Moreover you better read this domain


#10

This isn’t anything to do with the AUR package, if that’s what’s at fault.

If the issue is the non-working printer, that’s a different thing entirely.

Can we get some clarification as to what the purpose of this thread is?


#11

Try just to uninstall hplip and then install it again

sudo pacman -R hplip
sudo pacman -S hplip

#12

Still not clear why I can’t get my printer to work. . . .the hplip-plugin is needed to run my printer. There are a lot of Hp printers that need this plugin in order to work. The file signatures don’t match when I try to install it from the AUR repository.
Whats the sense of having a Hplip file if you can’t run your printer without and updated plugin with signatures? I’m not placing the blame on anyone. The plugin needs to be maintained for validity purposes with the hplip file.

Rich :wink:


#13

I pointed at the problem here. Hope it helps. If only my skill would be a little higher.


#14

That looks like a good exchange to me. :slight_smile:


#15

You need to grab its PKGBUILD from AUR, and update its md5sums with updpkgsums and build it with makepkg

If you don’t know how to do the above, I suggest you have a read about how AUR works and what to do with it. It might makes you slightly more understanding

https://wiki.archlinux.org/index.php/Arch_User_Repository

or

yaourt -G hplip-plugin
cd hplip-plugin
updpkgsums && makepkg -sci

#16

There’s more discussion on the AUR package page - it’s not a simple matter of updating the checksum as the files have moved on the source server. The package maintainer is looking for a solution.


#17

Ah sorry, I was too focusing on reading OP’s logs and forgot to check AUR comments as well.


#18

…from the maintainer

@banji and others: I’m sorry to inform you that there is a problem with 3.17.9. since HP has moved the files so the source in PKGBUILD ist not valid anymore. There is a bug report and hopefully I can find a work around. It sure will work again with 3.17.10. See bug-report:

https://bugs.launchpad.net/hplip/+bug/1727628

Disappointing, so I still need “the wind blows”.


#19

I’ve been trying to install my HP Pro Laserjet MFP M125nw, but the hp-setup program tells me that the plugin file is corrupted. The driver version is 3.17.9. Version 3.17.10 is also corrupted. Is there a way to install the driver manually?

Here’s what the setup tells me:

Checking for network connection…
Downloading plug-in from:
warning: manjarolinux distro is not found in AUTH_TYPES
Plugin is not accessible. Trying to download it from fallback location: [http://hplipopensource.com/hplip-web/plugin/hplip-3.17.9-plugin.run]
error: /home/grgaud/.hplip/hplip-3.17.9-plugin.run file does not match its checksum. File may have been corrupted or altered


(mod edit: threads merged)


#20

…news from the maintainer:

Due to the bug described here https://bugs.launchpad.net/hplip/+bug/1727628 I’ve dediced to update hplip-plugin to 3.17.10 even though hplip is not even in [testing], yet (as of 2017-10-28). So you need to do the following steps:

  1. Update hplip to 3.17.10 for your architecture using abs:
    https://wiki.archlinux.org/index.php/Arch_Build_System

  2. If makepkg complains about gpg keys, import the public key with:
    $ gpg --recv-keys [key]

  3. Install the newly build hplip with

pacman -U [package]

  1. Build and install hplip-plugin from AUR

  2. et-voila you can use your printer now :slight_smile:

…so we have to wait a little bit and use the usb cable. @philm is step 1 possible in manjaro?