HP Zbook with Hybrid Quatro T500 - not going well with manjaro

Hi ,

I got a Zbook with Quatro T500 but unfortunately every Arch distro I have tried to install including Manjaro is not working properly.
Most of the times it freezes because of the Graphic Card Issues.
I have tried and install different drivers but no luck. if you have any ideas of what to do let me know.

However I have tried and install MX Linux and everything is working fine smooth and fast.

How comes that MX Linux is working fine and not an arch based distro???

I wanted to install Manjaro but it seems that is impossible …

If you have any ideas or things to try please let me know

Best regards

Hello @wolfyrion :wink:

Let us at least know what system you are running:

Just the model name is not enough.



Is using a hybrid graphic card and that is the problem

Discrete: NVIDIA® T500 (4G DDR6)

Integrated: Intel® Iris® Xᵉ Graphics

@wolfyrion Unfortunately, you didn’t read the information at the link. There is a simple command, which provides common necessary information. In general one need the chipID for example. So I can’t help you here…

This is the command in short form:

inxi -Fazy

The problem is not the hybrid card, but must be the intel (i915) driver (just a guess). I would rather think that a function on the newest drivers does not play well with your intel gpu. A journal log or kernel messages could say more:

# 0 is the current boot and -1 the previous and so on
journalctl --boot 0 --no-pager
sudo dmesg

However… nobody can say anything without information. :man_shrugging:

Keep in mind, ArchLinux and therefore also Manjaro have bleeding edge software what means that older hardware could need some exceptions to work properly.

Have in mind that I cannot post anything or use the pc since the PC is freezing…

@wolfyrion ok I see… I did not expect that it is everytime the case.

However… on command line (if network is working), you can run these commands to upload it:

For example:

inxi -Fazy | curl -F 'file=@-' https://0x0.st

It will print a short link on the screen, which can be posted here.

EDIT: I cannot see which kernel version you are running. Since the intel driver is baked into it, try maybe the LTS version with version 5.4: https://download.manjaro.org/xfce/21.2pre1/manjaro-xfce-21.2pre1-minimal-211119-linux54.iso

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.