Hp laptop audio drivers

Hi, I just installed manjaro on my hp envy 13 ah0051wm and everything is working fine but the front B&O speaker doesn't seem to work whatever i do in pulse audio.The bottom firing (low volume) stereo speakers work just fine though.I cant seem to find any solutions online.

If not already installed install

sudo pamac install pavucontrol

pavucontrol start in Terminal with

pavucontrol

Nope still says stereo speakers and volumes to adjust each side

Please post the output of

inxi -Fxxxz

You can run this command in the terminal.

Also, take a look at this article. It gives a good listing of information you need to post when asking for help.

How to Provide Good Information in your Posts

Sorry! I'm new to the forums but here is the ss

@stardestroyer Just a note, in the future, you can use your mouse pointer to select all the text needed from the terminal. Once the text is highlighted, right click and select "Copy". You can then paste it into the reply window of the forum.

Okay, how many speakers do you have? Are there 2 up top by the bottom of the screen and 2 under the keyboard?

Okay alright. Yeah i think there are 2 up at the top and two at the bottom of the laptop.Top 2 don't work.

Okay, go to the terminal and type: sudo alsamixer and enter in your password.

This will open a program that allows you to adjust audio settings.

Press F6, this will allow you to select which sound card you are adjusting.

Select the Intel sound card.

This will bring up a listing of all the sound outputs and inputs on your system.

Example from my laptop:

The left and right arrow keys will let you select an output, and the up and down arrow keys will allow you to adjust the level (volume).

Look to see how many speakers are listed. If there are more than one set, see if the second set are muted. If they are, raise their volume by using the arrow keys.

This will tell me if the system is seeing the speakers at all.

If you need to, go ahead and post a screenshot.

@stardestroyer I am posting this before your reply to my last post, because it is late here, and I will be going off-line for the evening. If the above post does not fix your issue, read on. If it does, you can ignore this post.

If you only see one set of speakers in alsamixer , we need to adjust a configuration file.

  1. Go to the terminal and type: sudo nano /etc/pulse/daemon.conf

  2. Scroll down to the following line: ;default-sample-channels = 2

  3. Edit this line so it looks like this default-sample-channels = 4 Notice I changed the number to 4 and removed the ; This line tells the system how many speakers are attached to your sound card.

  4. Press ctrl+x to exit and Y to save the file when asked.

  5. Restart your computer.

  6. Once your computer has restarted and you are at the desktop. Test your speakers.

  7. If you are not getting sound, or it is of a very low volume, go back to alsamixer and make sure the speakers are not muted.

Your laptop is unique in that is has two sets of speakers for each channel. My last laptop, Asus G-75VW, also had multiple speakers for the left and right channels. I had to do the above to get all the speakers working properly.

Please let me know the results.

I have tried all the above steps and the problem still persists

Here is the pic of the config file

Hi @linesma I think i've found the solution here https://bugzilla.kernel.org/show_bug.cgi?id=189331#c258 but i have no idea what this means or how to do it
according to comment #258 i have to

Inspired by comment #250, I finally got all 4 speakers to work (including volume control) on my x360 13-ae0xx. I tested this on a clean install of Ubuntu 18.04.2. Using HDAJackRetask, I overwrote the following pin values: -

  • Set pin 0x14 to "Internal speaker"
  • Set pin 0x17 to "Internal speaker (back)"
  • Set pin 0x1e to "Dock Line out"
    When I only overwrote 0x14 and 0x17, I also had all 4 speakers work but volume control was missing. Frankly I don't understand why setting pin 0x1e to "Dock Line out" fixes the volume control, but I believe that pin 0x1e is somehow necessary for volume control, while pins 0x14 and 0x17 drive the front and rear speakers respectively.

Can you help me perform the fix because I have no idea what any of this means

1 Like

@stardestroyer Did you check your settings in the "sound" section of System Settings to make sure that you have 4 speakers enabled? I do not use XFCE, but I believe the setting can be found in "Volume Control".

I am not familiar with HDAJackRetask myself. I will look into it. Until then, I would like you to try the following.

  1. Go to the terminal and type: sudo nano /etc/pulse/daemon.conf

  2. Scroll down to the following line: ;default-channel-map = front-left,front-right

  3. Edit this line so it looks like this: default-channel-map = front-left,front-right,rear-left,rear-right Notice I added the rear-left and rear-right values and removed the ;

  4. Press ctrl+x to exit and Y to save the file when asked.

  5. Restart you computer.

  6. Once your computer has restarted and you are at the desktop. Test your speakers.

  7. If you are not getting sound, or it is of a very low volume, go back to alsamixer and make sure the speakers are not muted.

NOTE: You can copy the text in Nano the same way you can in the terminal. Please do this when you are posting text. Screenshots can be hard to read. The screenshot for alsamixer is okay.

Hey i tried what you said and it didn't work so I downloaded HDAreset jack and put those values every speaker is working properly as though in windows now.Thanks for helping!

1 Like

Glad to hear that. Enjoy!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by