HP Folio1040 boot device not found

Hi all, I was using Ubuntu for few years, now I am trying to switch to Manjaro. but after I installed the Manjaro, it is not able to boot but showing “boot device not”

Below are the steps I did:

  1. download the iso file from Manjaro from website
  2. use Rufus on windows to burn the iso to the USB driver with default options
  3. set my laptop(HP Folio1040) in BIOS to boot from USB drive
  4. install the Manjaro to the SSD dirve, with options “erase data and install Manjaro”, others are all default options.
  5. after installation finshed, boot up from SSD drive, shows “boot device not found”

with the same method above, I can install Ubuntu successfully.

Any ideas?
Thanks in advance.

Hi,
If using rufus you must use ‘dd’ mode.

Thanks for the reply, use “dd” will only affect the iso image written to the USB drive, As long as the USB drive can boot up, I think the issue i am facing in the Manjaro installation phase, something like particular partition needed?

BTW, I also tried to wirte the iso image to the USB driver under Linux with flowing command:
#sudo dd if=manjaro-xfce-17.1-stable-x86_64.iso of=/dev/sdc bs=4M status=progress
After installation, it is the same, still shows “boot device not found”

Try booting (after ‘failed’ installation) this way.
When/If booted up to installed Manjaro OS, provide at its terminal.

sudo parted -l
efibootmgr
findmnt -s
sudo blkid

ps: parted -l --> small ‘L’
please include your input commands as well as output, thanks
if error message, provide error message as well

2 Likes

Hi gohlip,
whit the instructions I am able to boot into the isntalled Manjaro OS.
Here are the output of the command:
[tq@tq-manjaro ~]$ sudo parted -l
Model: ATA LITEON IT L8T-25 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 247GB 247GB primary ext4
2 247GB 256GB 9449MB primary linux-swap(v1)

Model: hp v220w (scsi)
Disk /dev/sdb: 8039MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 1833MB 1833MB primary boot
2 1833MB 1837MB 4194kB primary esp

[tq@tq-manjaro ~]$ efibootmgr
EFI variables are not supported on this system.
[tq@tq-manjaro ~]$ findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/ UUID=e4a2370f-8e6d-47ac-b3da-59d66ebcdb95 ext4 defaults,noatime,discard
swap UUID=b75b018a-cc02-4fcf-ae14-71ea8bfa9c69 swap defaults,noatime,discard
/tmp tmpfs tmpfs defaults,noatime,mode=1777
[tq@tq-manjaro ~]$ sudo blkid
/dev/sda1: UUID=“e4a2370f-8e6d-47ac-b3da-59d66ebcdb95” TYPE=“ext4” PARTUUID=“f2d31dd1-01”
/dev/sda2: UUID=“b75b018a-cc02-4fcf-ae14-71ea8bfa9c69” TYPE=“swap” PARTUUID=“f2d31dd1-02”
/dev/sdb1: UUID=“2018-03-27-18-52-47-00” LABEL=“MJRO1717” TYPE=“iso9660”
/dev/sdb2: SEC_TYPE=“msdos” LABEL=“MISO_EFI” UUID=“18E3-676A” TYPE=“vfat”

Okay, boot up to Manjaro again (same method) and at terminal

sudo pacman-mirrors -f 5
sudo pacman -Syyu
sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

That should do it.
Welcome to Manjaro.
Cheers, take care.

1 Like

Hi gohlip,
I have the same problem. I have done all steps but then boot device still not found.

  1. I have booted into the installed Manjaro using usb boot.
  2. Follow your post:
    sudo parted -l
Model: ATA ST9250315AS (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  107GB  107GB   primary  ext4
 2      107GB   110GB  2150MB  primary  linux-swap(v1)

efibootmgr

EFI variables are not supported on this system.

findmnt -s

TARGET SOURCE                                    FSTYPE OPTIONS
/      UUID=bd0cd8c8-f369-4e58-b4a3-8d70929f59ea ext4   defaults,noatime
swap   UUID=222f3365-1699-4092-889b-55d080e81aa9 swap   defaults,noatime

sudo blkid

/dev/sda1: UUID="bd0cd8c8-f369-4e58-b4a3-8d70929f59ea" TYPE="ext4" PARTUUID="f847bb12-01"
/dev/sda2: UUID="222f3365-1699-4092-889b-55d080e81aa9" TYPE="swap" PARTUUID="f847bb12-02"

Then continue follow this:

sudo pacman-mirrors -f 5
sudo pacman -Syyu
sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

Eveything success

Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

But still Boot device not found after reboot :frowning:
(And I’m using Manjaro Deepin)

Okay, understand.

Now boot up again, just do one command
sudo parted /dev/sda set 1 boot on

Reboot.

ps; Since you have only one OS, your grub menu will not appear.

3 Likes

Yeahhhhh, it worked.
Thank you so muchhh !!!
ps: grub menu appeared :smiley:

1 Like

Welcome.
ps: Nice dog. What beer is that? Haven’t seen it before.

Hi Gohip,
Thanks for the help, it works for me too.

Could you explain the reason why the extra grub settings are needed for Manjaro installation for our PC?
Thanks again.

There could be several different reasons and it is difficult to say for sure. One of the reasons may be the installer failed installing the bootloader and could be that in your case. Whatever, reinstalling the bootlader after the installation should make it work.

In cutee’s case, I think that the partition table is not set properly [1] and so a boot flag is necessary to tell the bios where the boot device is.

[1] - A disk bought off the shelf is raw and not partitioned (as in gpt or msdos). Creating partitions before setting the disk to gpt or msdos will not ‘identify’ the disk to the bios and it has to ‘guess’. A boot flag will make the bios ‘more sure’. That’s putting it in human terms. :grin:

1 Like

Thanks very much for the help. :slight_smile:

1 Like

What beer is that? Haven’t seen it before.

it’s Beck’s from Germany :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.