HP device manager stopped working and couldn't fixed it with usual stuff

Hi guys,

I had multiple times problem with hplip, and usually when I reinstall printer (and sometimes driver) the problem is gone.

But this time it didn’t work.
First it couldn’t fetch driver “file does not match checksum”
Than I tried to install it from the command line
sudo hp-setup -i

but it didn’t work this time.

I tried to reinstall hplip and now it ads the printer that is always in the state “Busy”.

What would be the next steps to try, I wonder?

Installed version is 1:3.22.6-1

The usual stuff? What stuff?

To me it looks like you are taking rounds with something downloaded from HP - and is usually a bad idea - as a lot of things can go wrong - e.g. overwriting system files with incompatible versions.

And the hp toolbox app requires python-pyqt5 to work - which may explain why you cannot get it working.

It also appears to be a genuine xyproblem where you have tried a lot of things which may have worsened the issue and thas making it very difficult to provide any meaningful response.

Sounds like a custom package to me

Manjaro repo has a meta package containing everyting you need to print - and likely something you don’t need - in any case

sudo pacman -Syu manjaro-printer

How is the printer connected and which model is it?

It can be anything from bad cable, no response to tcp/ip request - even the wrong driver can do that.

Aarhus I assume the usual stuff would be an hp printer not working the one time in weeks you actually want to print something. The usual fix us to run the hp manager again, which requires the hplip-plugin to be installed. Trying to di this via the hp-manager does result currently in the bad checksum warning.

This is nit necessarily a Manjaro problem, but an HP problem.

The printer is HP M1132. As @Alchemix said, with HP printers sometimes it just stops working, usually once in a few weeks/months. The usual fix is:

  1. to remove the printer, and add it again
  2. remove the printer, reboot the computer, add the printer
  3. remove the old printer, use hp-setup to reinstall drivers and setup the printer

So apparently with the latest manjaro version, hp-setup cannot fetch the driver.
Since this project is maintaned by hplipopensource (.com) I’ll open that page to try to solve the problem if that doesn’t help, the last stage I can do is to email Arch packager.

…arch/manjaro are rolling releases, new hplip >>> new plugin.

Install it from HP:

…install a new matching plugin. :point_up:

Hi, @banjo I have installed the lastest plugin, but it still always shows my printer in the “Busy” state. (after I delete the printer and readd it)

The printer works fine from Windows.

I have created an entry in official launchpad:

NO sudo ! >>> hp-setup -i

from launchpad


USB HP_LaserJet_Professional_M1132_MFP Required - - OK Node:'/dev/bus/usb/003/006' Perm:' root lp rw- rw- rw- rw- rw- r--'

Checking Permissions....

Checking for Configured Queues....
warning: Fail to read ppd=/etc/cups/ppd/HP_LaserJet_Professional_M1132_MFP.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/HP_LaserJet_Professional_M1132_MFP.ppd
warning: Could not complete Queue(s) configuration check

…if the printer is not configuered correct, my next question would be if dual-boot is configuered correct.

My way to install HP printer:

1.) install manjaro-printer, for scanning (my preference) simple-scan.

sudo pacman -Syu manjaro-printer simple-scan

2.) disable firewall, you can set rules later.

3.) add yourself to the sys group.

sudo gpasswd -a yourusername sys

4.) enable cups from terminal.

sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

…from terminal:
hp-setup -u
(no sudo!! …you will be prompted to give permission when needed)

…when terminal says “done”, close terminal, open HP Device Manager from menu
and set up your preferences.

5.) If you need a plugin, be careful when using AUR-plugin. It is not always in sync with manjaro stable.
Watch out for matching version. When you test scanning/printing hp-setup will ask you to install the plugin.
Prefer the option to get the plugin directly from HP, whether loaded automatically or manually.

Banjo, I’m now telling you a secret you might not have known, I have ever only installed the hplip from the Manjaro repository. Not AUR or nor the downloaded driver. This problem ist still persisting.
In all honesty, the snide way you reply here is the reason so many Arch based communities have a poor reputation.

As I wrote before I am aware that this is primarily an HP problem, not a Manjaro problem.

Don’t fret about being mentioned when you’re hijacking a conversation.
I can also only give a general answer to general statements without an error report.
The symptoms you describe are largely the result of a rolling release. With e.g. Ubuntu/Mint this would not have happened. I feel the same way, I don’t need the printer for weeks, and then… first a new plugin.

Maybe this does not apply to you, but in all honesty, this is most of the time a configuration problem.