HP Color Laser MFP 178nwg Installation

Hallo,

habe hier einen süßen Lenovo U160 mit Pentium U5400 4GB RAM und ner 120GB SSD.

Hatte die ganze Zeit die I3 Version von Manjaro drauf, jetzt musste ich der bedienerfreundlichkeit und Homeschooling auf XFCE wechseln. Habe soweit keine Probleme bis auf den Drucker.
Bisher war es nicht notwendig für mich mit Linux einen Drucker zu verwenden und wenn doch war es bei meinem alten Billigdrucker keine Sache über USB.

Mit dem jetzigen HP Color Laser MFP 178nwg verhält es sich jedoch anders, habe ihn über LAN im Netzwerk. Mit Win10 und Android ohne Probleme, nur HP Smart und CUPS finden ihn nicht.

Sollte halt so funktionieren dass wenn mein Junior oder meine Frau im EG auf Drucken drücken, es im OG rauskommt.

Hallo rikscha,
bei HP würde ich es immer als erstes mit dem Paket hplip versuchen.
https://www.archlinux.org/packages/extra/x86_64/hplip/

viele Grüße gosia

hplip ist ja auch im Packetmanager, das hab ich versucht zu installieren, jedoch kam dann eine Meldung von Abhängigkeit von ... ich weis es leider nicht mehr, müsste heute Abend schauen. Bin mir auch nicht mehr sicher obs im AUR oder Offizel war, jedenfalls war es eine niedrigere Versionsnummer als direkt von HP.

Hallo rikscha,
hplip ist in den offiziellen Repos.

das heisst jetzt, Du hast die HP-Version von hplip installiert?

viele Grüße gosia

wenn ich das so richtig verstanden habe nicht. Ist noch alles frisch neu aufgesetzt.
Aber wie gesagt kam dann eine Fehelermeldung und die Installation wurde abgebrochen.

Nagel mich da bitte jetzt aber nicht fest, bin gerade auf der Arbeit und würde am Abend dann nochmal drüberschauen. Hab nicht so schnell mit einer Antwort gerechnet. :wink:

Hallo rikscha,

Tja, wir sind hier von der schnellen Truppe :wink:
Aber mach dir keinen Stress. Wenn du Zeit hast probiere es nochmal mit der Installation von hplip aus den Manjaro-Repos und im schlimmsten Fall postest Du die Fehlermeldung.

viele Grüße gosia

1 Like

Hi gosia,

hab nicht das aus den Repos sondern von der Website genommen.

Aus dem Logfile:

plip-install[1787]: info: :
hplip-install[1787]: info: :[01mHP Linux Imaging and Printing System (ver. 3.20.3)[0m
hplip-install[1787]: info: :[01mHPLIP Installer ver. 5.1[0m
hplip-install[1787]: info: :
hplip-install[1787]: info: :Copyright (c) 2001-18 HP Development Company, LP
hplip-install[1787]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hplip-install[1787]: info: :This is free software, and you are welcome to distribute it
hplip-install[1787]: info: :under certain conditions. See COPYING file for more details.
hplip-install[1787]: info: :
hplip-install[1787]: info: :Installer log saved in: [01mhplip-install_Sat-25-Apr-2020_21:14:08.log[0m
hplip-install[1787]: info: :
warning: manjaro linux distro is not found in AUTH_TYPES
error: You are running the installer as root. It is highly recommended that you run the installer as
error: a regular (non-root) user. Do you still wish to continue?
hplip-install[1787]: info: :
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: manjarolinux-20.0 version is not supported, so all dependencies may not be installed. However trying to install using manjaroli>
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mINSTALLATION MODE[0m
hplip-install[1787]: info: :[01m-----------------[0m
hplip-install[1787]: info: :Automatic mode will install the full HPLIP solution with the most common options.
hplip-install[1787]: info: :Custom mode allows you to choose installation options to fit specific requirements.
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mINTRODUCTION[0m
hplip-install[1787]: info: :[01m------------[0m
hplip-install[1787]: info: :This installer will install HPLIP version 3.20.3 on your computer.
hplip-install[1787]: info: :Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mDISTRO/OS CONFIRMATION[0m
hplip-install[1787]: info: :[01m----------------------[0m
hplip-install[1787]: info: :Distro appears to be Manjaro Linux 20.0.

hplip-install[1787]: info: :
Initializing. Please wait...
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mINSTALLATION NOTES[0m
hplip-install[1787]: info: :[01m------------------[0m
hplip-install[1787]: info: :Enable the universe/multiverse repositories. Also be sure you are using the Manjaro "Main" Repositories. S>
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mSECURITY PACKAGES[0m
hplip-install[1787]: info: :[01m-----------------[0m
hplip-install[1787]: info: :AppArmor is installed.
hplip-install[1787]: info: :AppArmor protects the application from external intrusion attempts making the application secure
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mRUNNING PRE-INSTALL COMMANDS[0m
hplip-install[1787]: info: :[01m----------------------------[0m
hplip-install[1787]: info: :OK
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mMISSING DEPENDENCIES[0m
hplip-install[1787]: info: :[01m--------------------[0m
hplip-install[1787]: info: :Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not install>
hplip-install[1787]: info: :Package-Name         Component            Required/Optional
hplip-install[1787]: info: :xsane                scan                 OPTIONAL

hplip-install[1787]: info: :policykit            gui_qt4              OPTIONAL
hplip-install[1787]: info: :python3-notify2      gui_qt5              OPTIONAL
hplip-install[1787]: info: :python3-pyqt4-dbus   gui_qt4              OPTIONAL
hplip-install[1787]: info: :python3-pyqt4        gui_qt4              REQUIRED
hplip-install[1787]: info: :python3-pyqt5-dbus   gui_qt5              OPTIONAL
hplip-install[1787]: info: :python3-pyqt5        gui_qt5              REQUIRED
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
hplip-install[1787]: info: :[01m-------------------------------------[0m
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python3-pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
warning: Missing REQUIRED dependency: python3-pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mINSTALL MISSING OPTIONAL DEPENDENCIES[0m
hplip-install[1787]: info: :[01m-------------------------------------[0m
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'gui_qt4': policykit (PolicyKit - Administrative policy framework)
warning: Missing OPTIONAL dependency for option 'gui_qt4': python3-notify2 (Python libnotify - Python bindings for the libnotify Deskt>
warning: This installer cannot install 'python3-notify2' for your distro/OS and/or version.
warning: Missing OPTIONAL dependency for option 'gui_qt4': python3-pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: This installer cannot install 'python3-pyqt4-dbus' for your distro/OS and/or version.
warning: Missing OPTIONAL dependency for option 'gui_qt5': policykit (PolicyKit - Administrative policy framework)
warning: Missing OPTIONAL dependency for option 'gui_qt5': python3-notify2 (Python libnotify - Python bindings for the libnotify Deskt>
warning: This installer cannot install 'python3-notify2' for your distro/OS and/or version.
warning: Missing OPTIONAL dependency for option 'gui_qt5': python3-pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
warning: Missing OPTIONAL dependency for option 'scan': xsane (xsane - Graphical scanner frontend for SANE)
hplip-install[1787]: info: :
hplip-install[1787]: info: :
plip-install[1787]: info: :
hplip-install[1787]: info: :[01mCHECKING FOR NETWORK CONNECTION[0m
hplip-install[1787]: info: :[01m-------------------------------[0m
hplip-install[1787]: info: :Network connection present.
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mRUNNING PRE-PACKAGE COMMANDS[0m
hplip-install[1787]: info: :[01m----------------------------[0m
hplip-install[1787]: info: :sudo pacman -Sy (Pre-depend step 1)
hplip-install[1787]: info: :OK
hplip-install[1787]: info: :
hplip-install[1787]: info: :
hplip-install[1787]: info: :[01mDEPENDENCY AND CONFLICT RESOLUTION[0m
hplip-install[1787]: info: :[01m----------------------------------[0m
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
lease wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm python-pyqt4'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369
warning: Some HPLIP functionality might not function due to missing package(s).
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm pygtk'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm pygtk'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm pygtk'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm pygtk'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369
hplip-install[1787]: info: :Running 'sudo pacman -S --noconfirm pygtk'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites
hplip-install[1787]: info: :
note: Please check for more information at http://hplipopensource.com/node/369

Also was ich davon versatanden habe, ist Manjaro wird offizell nicht unterstützt und das von python wurde nicht installiert.

Hallo rikscha,

das ist schlecht. Wenn vorhanden, immer die Version aus den Repos benutzen. Aber was ich nicht ganz verstehe, sind die Hinweise auf pacman

die kommen auch vom Installations-Skript der offiziellen HP-Seite? Ganz abgesehen davon wird mir bei der Benutzung der Option --noconfirm immer ganz übel.
Also versuche bitte nochmal die normale Installation mit pacman
sudo pacman -Syu hplip
oder welches Werkzeug Du immer bevorzugst. Ich hoffe, daß das HP-Skript nicht schon zuviel Unsinn ins System gespült hat.

viele Grüße gosia

Hi gosia,
hab nochmal XFCE nochmal neu installiert, war kein Problem.

Bei sudo pacman -Syu hplip kam das dabei raus:

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
nss: /usr/lib/p11-kit-trust.so existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Hallo rikscha,

sudo pacman -Syu --overwrite /usr/lib\*/p11-kit-trust.so

https://www.archlinux.de/news/33215-Manueller-Eingriff-erforderlich-nss-und-lib32-nss

viele Grüße gosia

Hallo gosia,

da sind wir wieder :grin:.

Update und Installation von hplip haben jetzt funktioniert.

Über die HP Software hats leider wieder nicht gefunden, jedoch über die CUPS website.

Allerdings bekomme ich dann noch die Fehlermeldung:

"Drucker kann mit den angegebenen Optionen nicht drucken."

Meinst du das hat auch was damit zu tun?

Hallo rikscha,

Wird wohl so sein, aber an der Stelle hat meine Glaskugel einen Sprung :wink: Welche Optionen?

Mein HP lebt nun schon länger nicht mehr, aber ich glaube, der HP sollte schon mit hp-setup erkannt werden, damit es überhaupt funktionieren kann. Also probiere mal die beschriebenen Advanced Options
https://wiki.manjaro.org/index.php?title=HP_All-In-One_Gerät_einrichten#HP_Setup_ausf.C3.BChren

viele Grüße gosia

Hallo gosia,

ich habe noch nicht aufgegeben! :upside_down_face:

Der Drucker scheint so wie es jetzt aussieht zu funktionieren. Nur bei PDF's kommen da ne Menge "Fehler" zusammen. Ich wollte nur eine Briefmarke ausdrucken und es kamen ca. 20 Seiten mit jeweils 1-2 Zeilen mit Zeichen (Smileys, Herzchen usw) und dazwischen viele Leerseiten raus. Das selbe unter Ubuntu 20.04.
Ich weis, dass der Drucker ofiziell keine Linuxunterstützung hat, macht aber die ganze Sache noch seltsamer für mich.

Hallo rikscha,
wenn noch nicht geschehen probiere mal ghostscript zu installieren
sudo pacman -S ghostscript

sollte das auch nicht helfen fällt mir vor lauter Verzweiflung nur noch ein, den Treiber splix zu installieren. Das ist eigentlich für Samsung, speziell für die Druckersprache SPL, die auch dein HP versteht.
sudo pacman -S splix
Beim ausprobieren von pdf-Drucken nur zwei Blätter einlegen, das spart Papierkosten :wink:

viele Grüße gosia

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by