[HowTo] Post command output and file content as formatted text

Difficulty: ★☆☆☆☆

Formatting differences

  • Discourse – this forum’s engine – uses Markdown to format its posts, and removes “unnecessary” whitespace.
  • Terminal commands often produce output formatted so that they are better readable by the user, taking advantage of the monospaced font used.
  • Programming code often rely on indentation to make it more readable.

Using preformatting in Markdown

Markdown includes a pattern to provide preformatting when necessary.
You only need to put the part to format between two lines of three backticks, like so:

```
This text will be preformatted.
```

:warning: Do note confuse the backtick ` character with the single quote or double quote ".

:star: If you don’t find the backtick key on your keyboard, you can achieve the same result by clicking the Preformatted text </> button in the posting form, or with Ctrl+E.

:star: The posting form has a preview feature, allowing you to check whether you correctly set preformatting before posting.

:star: You can edit your own posts. Make use of this to correct the formatting when asked to.

Without preformatting:

$ inxi -m
Memory:
RAM: total: 15.64 GiB used: 6.51 GiB (41.6%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.

With preformatting:

$ inxi -m
Memory:
  RAM: total: 15.64 GiB used: 6.51 GiB (41.6%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
12 Likes
[HowTo] Find error logs
Network problem
No default controller available - Bluetooth
What grub modules are preloaded by default?
Kodi Crashes/closes with any addon
Steam Client: Could not connect to Steam Network... error
Steam crashes proton games while heroic and pure wine doesn't
A secondary connection of the base connection failed
Problem with starting the system, stuck in screen
Sound has gone from laptop
How to insert a command from a terminal on the forum?
Laptop lot hotter to the touch than it should be
Stuck on /dev/sda1 clean, files, blocks
VIM3 Manjaro 22 - Just Stops
System frequent freezes
Dev/sda2: clean **/** files **/** Blocks”
I insert usb and Manjaro crashes
Screen resolution not proposed
Mediatek MT7921e wifi driver issue
Audio crackles when changing volume (Pulseaudio)
Computer randomly restarts, regardless of OS
Updating linux initcpios... errors for old uninstalled kernel versions
Wi-Fi problem since the last update
Latest stable update 10/10/2022: failed to prepare transaction
[HowTo] get legacy 340xx NVIDIA drivers back
Display Corruption with RX 580
Booting is not possible
Low speed of network using Wifi connection
How to Install xDebug?
Visual glitch issue while using apps!
Dernière mise à jour manjaro nvidia écran noir
Wifi problem on fresh installation
Most/All games refuse to run or crash after updated packages and upgraded kernel to 5.19.1-3
Matériel - Contr^ole des FANS CPU/GPU/Boitier
Steam + Left 4 Dead 2 - KDE Session Closes
Manjaro freezes while boot
Screen flickering ASUS TUF Gaming F15
Speaker & Headphones not detected by Manjaro
High memory usage
First login fail with Gnome Extension enabled
QGnomePlatform not working/not respecting dark theme?
Error: failed to update DEB_Arch_Extra (no servers configured for repository)
Error: failed to update DEB_Arch_Extra (no servers configured for repository)
Error: failed to update DEB_Arch_Extra (no servers configured for repository)
Welcome and introduce yourself - 2022
Genymotion fail to run - virtualbox 7
Genymotion fail to run - virtualbox 7
Why refresh rate drops to 30Hz?
Touchpad not working out of the box
Mac Wi-fi issue
Genymotion fail to run - virtualbox 7
Clickup app for desktop
Genymotion fail to run - virtualbox 7
Login screen always opens on external monitor
How to install Google Chrome binaries?
Motherboard's included audio is not recognized
Error failed to prepare transaction(incalid or corrupted package
Headphones not recognized on startup
Buzzing noise from speakers when using external sound card
[HowTo] Find system information
Cleanupdate.desktop
I cant install linux
Very long firmware boot time
Can't boot since system update .Failed to start Load Kernel Modules
GDB Broken in latest release
Possible Malicious Linux.Xor.DDoS installed
[Stable Update] 2022-11-02 - Kernel, Plasma 5.26.2, Plasma Mobile Gear 22.09, LibreOffice, Virtualbox 7.0.2, Systemd, Mesa
Manjaro Plasma goes to Limited Connectivity after 5 minutes
No image on the second monitor when the nvidia driver is set,
System lag and slow rendering on both primary and external monitors when run on NVIDIA card
Manjaro does not boot after installing a new Kernel-dropped Into emergency shell, for people who think they have a big problem but are actually just noobs
Setting timeout for bluetooth controller
Tuxedo-Control-Center, tccd.service does not start
Network interfaces - info center only shows lo interfaces
Airpods pro low volume (applied fix but needs re-pairing)
Intermittent Internet Access
Buggy wifi in Manjaro KDE
Computer/manjaro not picking up webcam on laptop, have tried kamoso and guvcview
KDE-dev branch: GUFW Dead 20220923 ISO
Laptop doesn't any reaction on lid close
Discord Update / Error
Nvidia-Utils-Nvlax
Problem with AUR updates
Second Monitor problem
Second Monitor gone after initial setup from bootable pendrive
VLC closed after opening video files
Problem with AUR updates
After last update my computer is very laggy
VLC closed after opening video files
Installed bleachbit - now blank screen
Weird Screen after plugging in charger on low battery
Drive shown as empty after applying chmod
Intel Wifi card is not detected after Suspend crash (manjaro windows 10 dual boot)
Qbittorrent won't start
Mpv is taking time to intiate
Steam is not starts and not working
Is my app use a discrete graphics card (NVIDIA)?
Steam is not starts and not working
Is this a RAM issue?
No Wifi Adapter found
OpenGL don't work after update
Internet Connection breaks up regularly
Random crashes, programs not responding
Nvidia-smi: no devices were found
Reset mouse config to default
Nvidia-smi: no devices were found
CUPS: Unable to create PPD file
I am unable to delete a file that is using space in my usb pendrive and not showing that fille
PCM2902 Audio Codec USB mic not working
Unable to connect to wifi after update. Ethernet works fine
Laptop cpu is overheating
Red curtain of death after battery died
How do I configuring a new storage SSD?
I can't close my computer
Sudo issues and invalid or corrupt package
Lost Wifi Capabilities overnight
Is my cpu that bad
Update infinite loop
Screen Brightness Changing Randomly
A faliure occurred when I try to install chromium-wayland-vaapi
Bug report Manjaro Gnome kernel 5.16/5.17 sluggish/freezes on i5-8500 UHD630
Most of the time boots to black screen
Metaverse / Ufw firewall in practice => access Second Life with Phoenix Firestorm viewer
Only an external monitor is detected on Laptop after Update (NVIDIA)
Installing Drivers for AMD RX 6500 XT
Slow graphics issues after update 2022/06/12. Perhaps NVIDIA driver related
How to switch between audio controller profiles fast?
Sound not working Only Dummy output
One or more files did not pass the validity check when building android-studio
Problem with the graphics in Manjaro of my laptop lenovo z50
Tweak Manjaro to run faster than WIN10
My laptop's ui is way too small
I can't execute prime-run
Bluetooth adapter not found problem
Cant put Scale in 200%
On one of two Manjaro systems language support not working for pacman -Qi output
Did brightness depends from graphics cards?
Failure on build() when installing packages from the AUR
Four applications stopped working
App base on electron13 (13.6.9-1) start failed on kde (5.24.2) wayland session
Firefox frequently freezes, requiring browser restart
Media keys on lenovo keyboard SK-8823 stopped working
Serious wifi issues
Wine is not working on Manjaro linux KDE Plasma
Games freezes mid game along with display and few applications
Screen Rendering issue
Monitor not detected anymore after system/packages update
After installation I can only see one partition and its a read only
Cannot connect using bluetooth after swapping motherboard
Unable to write to non-system drives
No wifi since change to iwctl
Stable update is breaking my wireless connection
No Mic Input from my G935
Team Viewer / Anydesk problems
Mouse and keyboard not responding on laptop
NetworkManager: no secrets: No agents were available for this request
System won't start after Manjaro update
No wifi available on plasma kde
Can't connect to wifi
Mesa-amber 21.3.8-4
Second Partition filling up Root Partition
Torchlight II (Steam) wont launch
Qt5-base signature is unknown trust
How to run pam-auth-update?
Kdenlive does not work with Nvidia prime
Vulkan Radeon performance issues
Manjaro GNOME, "Activities" not response at initial, after search something works again
Nvidia not working on xanmod
Manjaro loads the graphical installer but freezes within the first second
Laptop doesn't conect to wifi after suspending
None of the wallpaper apps works
Stuck in Emergency Mode after update
Pc does not let you remove files from the flash drive
Battery status and icon missing
Cannot connect to LAN/Wifi after system wakes from suspended state
Manjaro won't boot after update, Nvidia problems
Baja Resolución de pantalla
Actualizar los drivers nvidia en mi sistema Manjaro 5.15.46-1-MANJARO
My dgpu is recognized on vulkan games but aint recognized on opengl
Can't boot when the power cable is not plugged in
How to make TP-Link Archer T3U work?
ProtonVPN " Unknown error occurred"
GNOME 42 broke my Bluetooth
Wirelesss mouse not working
Bug after update
Since Stable update 2022-07-18 & 2022-07-12, my system has high IO lag for first operations
How to apply themes for kde applications?
Wifi Device not found
How to put my desktop on windows-like sleep mode?
Trying to get my GPU to work
Black screen after latest update on linux 515
Just Tried Installing and Did NOT Work!
Don't run a command you don't know
Libopenvdb.so.9.1: cannot open shared object file
Unable to respond to a message
Which graphic driver should i install?
Dual display mixed up with last update - Same ID
Caffeine-ng not opening after new update
Fans keep spinning for no apparent reason
Cinnamon Lock screen will not allow keyboard password
Brightness at 100 but screen is very dim
I get the message that the package is wrong or corrupt
Rust GUI apps take a lot of time to build. Building gtk4?
Cannot update system any more - package manager freezes
Unable to get to chroot because my current login not in sudoers file
Graphics Driver Issues Likely; Potentially Power Issue
My camera drivers not working
Chromium crashing upon launch and never opening
Battle.net Issue to Start
Cannot boot up any type of windows after installing
Gazebo Installation Help through AUR or Paru
Not booting after an update (getting stuck/frozen at /dev/nvme0n1p2 clean ... files, x/x blocks))
My rtl8812au isnt working
Restart instead of shutdown manjaro
Cannot upgrade from AUR because of git: no tracking information for the current branch
An Issue with a Corrupt Firefox Browser
Support Kde plasma. please)
Package Manager Failed to prepare software
[Stable Update] 2022-11-02 - Kernel, Plasma 5.26.2, Plasma Mobile Gear 22.09, LibreOffice, Virtualbox 7.0.2, Systemd, Mesa
Ufw world writeable
Intel AX210 is not working correctly
[HowTo] Solve problems with the xone driver in Manjaro
Gnome-boxes crash on launch after cloning an other VM
Power throttling, CPU won't use all available power, weird CPU usage readings and stutter in all games
Database Error - Latest Update for Manjaro Gnome
Some software update via pamac is breaking the system, but I can't tell which one
Control Keys Not Working
Shortwave 1.3 update not compiling
Trouble updating Zoom using pamac - bad sha512sum
Hide fsck messages
JamesDSP running but no hearable effects
How can I stop fsck?
Wifi disapeared after downgrading the kernel
Fallo actualización de Betterbird
Headset only available for one account at a time
[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire
Cannot Connect to Database Server
XFCE Bluetooth drivers
Stuck on clean... files... blocks on boot
CommonIncludes.hpp exists in both libuinputplus and libevdevplus
Apres installation manjaro,impossible de faire les mises a jour
Calamares fails due to error concerning the EFI
[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire
SSH client side connection error
Fails to install bootloader
Can't install a DKMS module for a driver I need
Gens/GS crashes with segfault
Command not found: wireguard
Failure to update via System updates, 233 updates pending
Cinnamon doesnt show icons of open apps in bottom bar
Kwin_x11 use 99% of cpu
Keyboard not working on Asus Vivobook S 15 OLED K3502ZA
Steam games don't run (Native and via Proton)
Problem starting desktop
Veracrypt wxwidgets - assertion failed
Problems using dual monitors in Manjaro
Graphics Driver Issues Likely; Potentially Power Issue
Cache cleaning commands I forgot
Built vivado from AUR failed
Nvidia drivers and X11
Kernel panic after update 2022-11-14
Hide fsck messages
Errors in boot time discovered
When i wake up my computer,My screen will have flashing streaks
Manjaro stopped working after some time
Konsolerc already exists in filesystem
Strange problems with desktop theme
Facing very slow boot time
[Realtek RTL8111/8168/8411] Can't see wifi connections after manjaro installation
[HowTo] Request support
Cant open the settings App
Disabling touch pad does nothing. Stays active
Installation issues
ZFS, accessing harddrives
Broadcom 4360 wifi issue on MacBook Air 2013
Displayport-connected monitor not displaying anything
Where to report malware?
Slow boot times on Manjaro Kde
[ARM Stable Update] 2022-09-11 - Plasma 5.25.5, KDE Gear 22.08, Thunderbird 102, Firefox 104 and Kernels
[ARM Stable Update] 2022-09-11 - Plasma 5.25.5, KDE Gear 22.08, Thunderbird 102, Firefox 104 and Kernels
All my wifi access points disappeared
[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire
Required key missing from keyring
Ceph-libs build problem
Power savings options not applied (not saved)
Graphics Driver Issues Likely; Potentially Power Issue
Tonight's update failing - installing nvidia-utils (515.76-1) breaks dependency 'nvidia-utils=515.65.01' required by lib32-nvidia-utils
Erreur : la validation de la transaction a échoué (conflit de fichiers )
Erreur : la validation de la transaction a échoué (conflit de fichiers )
Cannot update NEW installation
Cannot enable Bluetooth
Stuck doing an update - dependencies in the way!
Keyboard Light Color Changing
Todays (6OCT22) update fail manjaro-pulse ↹ pipewire-v4l2
$HOME/.local/bin/ missing from PATH after update
GRUB corrupted (maybe) after fixing interrupted update process
Error during Dialect installation
WiFi on my HP laptop is very slow and ocasionally drops out
Error during Dialect installation
Apps Locking Up
Installed bleachbit - now blank screen
Not able to access other hdd partitions
Manjaro froze to black screen
[Testing Update] 2022-10-10 - Pipewire, Haskell, Python, Firefox, Thunderbird, GlibC
Conflicting dependencies when updating
Failed to start Mullvad early boot network blocker
OpenSSL version unavailable for python2
[Testing Update] 2022-11-08 - Kernels, GNOME 43, OpenSSL 3.0, Firefox, Thunderbird, Mesa, KDE Gear 22.08.3, LibreOffice, LXQt 1.2.0
How could I reset all display servers configurations on Bash? / Reset all app settings without uninstalling them?
Trouble while updating AUR packages
How to install Autodesk Maya in Manjaro?
NVIDIA broke their 3000 series graphics cards on Linux with a recent update
Internal microphone is not working in gnome
[Testing Update] 2022-11-08 - Kernels, GNOME 43, OpenSSL 3.0, Firefox, Thunderbird, Mesa, KDE Gear 22.08.3, LibreOffice, LXQt 1.2.0
Broadcom Wifi Driver missing after Kernel 6.0 update
Error when installing hydra
Unable to bring up the WiFi up after upgrading to 5.19 kernel
Newbie hardware issues
Multiple Display System Management - Asus Zenbook Duo
Top Bar Anomaly
Samsung NVME randomly goes down during activity
GTX 960 DP output not working properly on latest proprietary driver
KDE very high RAM and VRAM usage
External devices won't mount
Ssh: Could not resolve hostname alias <name>: Name or service not known
Ssh: Could not resolve hostname alias <name>: Name or service not known
Do I need Nvidia drivers with only an AMD APU?
Recovery from kernel update failure
Wifi problems after latest testing updates
Minisforum reports 120 TiB but over 450 GB of space available
Problem with shutting down/rebooting
Manjaro fail to install
Clarification with Flutter
Pinebook Pro Manjaro: Problems after OS Update/Upgrade
Unable to boot to manjaro (complete noob) been using it for a 3 months and out of nowhere this shows up
Fps drops almost to zero after few minutes
Nvidia utils update causing no boot
Nvidia utils update causing no boot
Something's wrong in out-of-the-box configuration of zsh
Problem is: No WiFi adapter found
My computer froze during an update
Nvidia utils update causing no boot
ERROR: A failure occurred in build()
Severe problems in Manjaro KDE on a laptop
Slow start up/boot time
[Realtek RTL8111/8168/8411] Can't see wifi connections after manjaro installation
My computer doesn't boot up
Wine doesn't start application
Need help with the graphics driver
Unable to update/build ceph-libs, electron16 & pdfsam
Openshot 3.0 fails to start
I have a problem with Mozilla Firefox
Gnome toolbar and menu text disappears
Your post in "Activar retroiluminación de teclado y desactivar ventilador svf14211clb"
[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon
Manjaro is „slow“ and how to know if i shall download the new kernel
Ssh problems since update
KDE Plasma 5.26.3 Frameworks version 5.99.0 - missing application & System tray icons - fresh install
Slow boot times on Manjaro Kde
Kernel linux 519 and 6.0 bluetooth failed module and hold driver not present
Gnome: cant set display to 4k@60Hz
Ssh problems since update
Allowed upload file extensions
[ARM Testing Update] 2022-11-20 - OpenSSL, Firefox, Thunderbird, Plasma, SystemD and kernels
Black screen after startx and monitor reads HDMI out of range 75.0 kHz / 60 Hz
I3wm first install no audio
Kernel update failed + new kernel is not installing
WiFi Driver Gets Removed After Every Update
After update, my external monitor doesn't get signal
Small bug in Files
Cant use second monitor
Despite trying numerous methods, my laptop goes to sleep over and over
Manjaro Budgie booting to black screen
How do I bring back the GUI when I start the kernel?
Oracle VM - Stuck at 20%
Ledger Live went missing from the start menu
Ethernetproblem kein Internet mehr
Login loop caused by Extension List extension
I cannot get Manjaro LIVE CD to boot
Red Exclamation Over Wifi Network
Network usb adapter not working even after installiing rtl8188gu-dkms-git
Faild to launch flatpak "Bottles". Getting libgtk-4.so.1 invalid ELF header issue
Failing to install because I have a GRUB password
Unstable wifi on Gnome
MSI Modern 14 with Ryzen 5 4500U touchpad detected but not working
[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox
Virtualbox transparency issue
Libtiff conflict - can't update depending packages
Wacom Intuos S - CTL-4100WL
Can't enable bluetooth - Manjaro XFCE dual-boot with Windows 11
Pipewire, no HDMI audio using the Asus i5 11400, gpu 730, pulseaudio works fine with all outputs.Tested with Kde, XCFE and Wayland
Pacman macht Probleme
OBS-Studio not working after last update
Steam not creating folder on new selected drive
Odd booting Behaviour/Boot Lottery On HP Elitebook 735
Linux keeps turning screen off after a couple of seconds, it's like a loop, go to the post 6 and look for the video link
Core dump on 3D Render in Kicad 6 - libEGL_mesa is suspect
Can't boot with kernels >5.15
How to install, a proprietary driver AMD Pro for W5500
The system freezes and nothing can be done until the reboot
No Steam games will launch
Manjaro XFCE suddenly freezes after last update
Manjaro stuck on boot screen
Unable to update: Failed to satisfy dependencies
Manjaro-cinnamon-settings and manjaro-gnome-settings are in conflict
How to install GEPH VPN on Manjaro Gnome?
[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon
I can't lower my brightness on gnome
Unable to update: Failed to satisfy dependencies
Nvidia dGPU not recognised by the bios and the OS (X13 2021, Manjaro (Sway) , Kernel 6.04)
My external HD mounts on different folders everytime I restart
Installing the software "flatCAM" fails
Best way to get h264 accelerated again?
Crashing back to login screen when launching game
Gnome-terminal won't work with Cinnamon desktop
Error download visual studio code
GNOME Manjaro no sound at all
Steam - disk read error
Corrupt database, cannot update
Corrupt database, cannot update
How to switch between audio controller profiles fast?
Сan't update packages
Realtek Audio not working
Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter type: USB no Wi-Fi adaptor found
Manjaro stuck at 60hz
How to disable HDMI subdevice
Сan't update packages
Sometimes losing files when I move them to another drive
MPV playing video lag
I cannot update my system
Failed to finalize live systems, loop devices, ignoring
VPN connection not working after update
Wifi is slow on manjaro gnome latest edition
PC crash when using controller
Have not been able to update in months due to AUR package failing to build
[Testing Update] 2022-09-24 - Kernels, Wine 7.18, KDE-git
Help to install espanso-wayland
Bluetooth devices not working
Installed Nvidia proprietary drivers and now can't boot into GUI

You can also use Ctrl + E on keyboard

Or 4 spaces at the start of a line

1 Like

HTML can be used as well:

<pre><code>
type or paste code here
</code></pre>

2 Likes

I found these resources helpful to learn about markdown, discourse, and the Manjaro forum.

You are only able to do that when you have the permissions, on the forum, to edit posts of others… (Which most users of the forum do not have)
But there is an easier way that works for all:

  • Select the part of the post you want to investigate in the post, then there should popup a “Quote” option you can click.
    Look at the quoted text the forum software prepared as your reply without posting that reply. :vulcan_salute:

I think something changed along the way. Don’t know when, why, or how. Anything I write would be a guess on my part. For example, most recently, I use to be able to create a poll, but I can’t any more. When I clicked the gear in the menu, there would be an item for it. Now there isn’t. Okay. :person_shrugging: It’s a little confusing because the discobot tutorial still demos creating a poll.

Thats because of trust level of the user account on the forum :wink:

Agree. Trust Level.

But, I don’t think it is documented what one can and cannot do, or how or something like that — and that is by design according to the folks at Discourse. Don’t want folks gaming the system. Argh :crazy_face: Not a big badge fan. But what stuck in my craw was, one day it disappeared. Don’t know. Maybe it was a bug fix or adm change. A lot of things change on the forum without notice, so I figured it is what it is, "c’est la vie.