[HowTo] Disable Sponsored Sites (e.g. Ebay, Amazon) in the Url Bar by Opening a new Tab since Firefox 85.0.2

I wouldn’t assume that, Mozilla wants to make money. :innocent:

Indeed! But I am wondering if they have intentionally done this modification or not…

Do you really think some sponsored commercial links could be added by mistake?

The Mozilla Foundation had some severe money difficulties these past few months. One has to bring back some cash.

Running Firefox 86.0-1, solution #1 doesn’t work for me and #2 doesn’t even exist (anymore?)…

Method 2 still exists:


I’ve never seen this. At first I thought it was Privacy badger but I’ve changed my mind.

I think it’s because I use the New tab tools extension .

1 Like

Not for me…2021-02-25 11-14-21

Weird… I have done these modifications with 85.0.2. In about:config, can’t you find browser.newtabpage.activity-stream.showSponsored or something similar? I have now update Firefox to its 86.0 version and it is still present there…

Yep, all set to ‘false’
pacman -Qs firefox local/firefox 86.0-1 (testing branch)

You are probably and unfortunately right. I wanted to give them the benefit of the doubt… Instead of doing that, they could have done a crowdfunding campaign like Wikipedia regularly does in order to make public their financial needs.

I don’t know if it makes a difference but I am on the stable branch.

pacman -Qs firefox
local/firefox 86.0-0.1 

Have you tried to reboot your machine (I don’t know if it can change something…)?

Yep, but we’re not running the same version.

And do you think downgrading and then changing this feature could somehow help?

Or maybe try to set browser.newtabpage.activity-stream.showSponsored and browser.newtabpage.activity-stream.showSponsoredTopSites temporarly and again to true and see if method 2 is still useful (or if the “Sponsored Top Sites” line reappears in your preferences menu).

A temporary solution would be also to install a new tab tool extension.

Another user of such a tool, a certain fiscalia, has no problem by using the Caret Tab extension.

New Tab Override is for instance recommended by Mozilla (I have not tested it).
I hope that it can help you.

Thanks for your efforts. None of the above works for me (or in version 86.0-1, for that matter). It’s not that important to me in order to install any extensions as a remedy.

Maybe somebody else on testing will chime in and either confirm it working or not…

UPDATE: I managed to get rid of the sponsored sites eventually by keyword-search ‘urlbar’ and ‘search’ in about:config and toggling/removing everything that looked suspicious (a bunch and a few at a time, so can’t say which one did the trick in the end)…

1 Like

Hi @anon88624618,

I just went thorough the list, for interest sake, and I’m going to go ahead and assume it’s because of either browser.urlbar.suggest.topsites or services.sync.prefs.sync.browser.urlbar.suggest.topsites.

There is, however, no way to confirm this, seeing as I haven’t gotten this behavior and am not going to do anything on purpose that might bring it back.


That one I didn’t touch so it may be the other one…

It might be. I don’t know. :man_shrugging:

Since trying doesn’t hurt I can confirm that toggling


brings back the sponsors… :smiley: