[HowTo] Bluetooth headphones paired, but no sound after a while

Here is a revised version with steps added, as requested!

Thanks @The_Quantum_Alpha. Your [How to] was easy to understand and resolved my issue

1 Like

:partying_face: oh! You are very welcome! !

Glad it helped! :grin:

You’re a good man!
I just bought these bluetooth headphones and they work flawlessly on Android.
On Manjaro KDE the bluetooth crashes five seconds after connection.
Damn Linux I was swearing, but then found this topic! Problem solved, thanks :muscle:

I paste the error for SEO to help fellow users searching for this:

nov 09 11:24:58 my-computer bluetoothd[852]: profiles/audio/avdtp.c:avdtp_connect_cb() connect to 00:00:00:00:00:00: Software caused connection abort (103)

and

nov 09 11:08:19 my-computer bluetoothd[852]: src/profile.c:record_cb() Unable to get Headset Voice gateway SDP record: Software caused connection abort
1 Like

This is wonderful news to me! :smile:

I’m glad that this can help you!

I wish you a wonderful day!

It works perfectly!

2 Likes

I think this technique helped my audio but it didn’t fix it. I’m trying to connect my Airpods Pro to my laptop. I can hear audio for a few seconds to a couple of minutes but audio starts to cut out and glitch, then stop altogether. I’ve tried a few techniques from the Arch forums on PulseAudio/Troubleshooting but nothing seems to fix my problem.

worked for me thank you :smiley :smiley:

2 Likes

Thanks man! I can now use my bluetooth earphones. I really appreciate it. :blush:

1 Like

That didn’t work for me, but here is what I did on top of that to make it work.

I have headphones that can also be switched off with button. After switching back on, they still didn’t auto connect.

I’ve done all what was said in the instructions, rebooted, nothing changed.

On top of that I edited sudo nano /etc/bluetooth/main.conf and on the very bottom of the file uncommented these lines:

AutoEnable=true
ResumeDelay = 2

Also I edited sudo nano /etc/pulse/system.pa and on the bottom added these lines:

load-module module-bluetooth-policy
load-module module-bluetooth-discover

Now when I switch on/off my headphones they autoconnect and work just fine.

Most Manjaro users are not running PulseAudio in system mode and should not need to change /etc/pulse/system.pa

What Is Wrong With System Wide | freedesktop.org/PulseAudio/Documentation

For most users It would be more effective to add changes to /etc/pulse/default.pa or create a custom user configuration ~/.config/pulse/default.pa

thanks…very informative tutorial…it help a lot…

I got the same issue and solved it by going to Pulse Audio Volume control → Output devices → Built in analog sterio port → Headphones (unplugged)

Hi,
I’m not running manjaro but i’m running arch, and the issue I had was that my PC would keep playing through the integrated speakers even though my bluetooth speaker was connected.

While your fix worked, the problem is that now my speakers don’t work anymore ! I reverted the changes and it’s back to normal now.

Any idea why it does this ? Any potential solution ?

Excellent! I’ve been wrestling with this since making the switch to Manjaro several months ago. This got my JBL Live300TWS buds working quite well. First run through it wasn’t working at all … but that was a keystroke error on my part. Now it’s great.

Thanks very much.

I think this finally solved my problem!!! Thank you so much!!!

I’m pretty happy with that - I had been thinking about figuring out a way to make the sound output switch automatically upon connecting bluetooth headsets. Didn’t think it would effectively be a one-liner - thanks a bunch.

Didn’t help buddy. Could you please look into my issue??

A post was split to a new topic: How do I use nano?

The latest manjaro system, did step by step as this, didn’t help. Any updates?