How to upstream the fix for "sddm-greeterrc not writable" error?

I got the same error as hxxps:// but it’s been a while since that was posted, and this is still happening. How do we get this change upstreamed so nobody else will have to search around to find the chown command to use?

The chown command:

sudo chown -R sddm:sddm /var/lib/sddm/.config

EDIT: change “hxxps” to “https” to make the link work. For some reason, the forum didn’t allow me to post a link…

Its not something that needs to be upstreamed.
The user (and you apparently) did something to modify the ownership of that file.
That created the problem … it didnt come downstream that way.

( signed: someone who has been using the same install with sddm since 2018 :slight_smile: )

The user (and you apparently) did something to modify the ownership of that file.

I did not, though. I only upgraded packages.

Are you sure?
Did you ever run something as root?
Maybe installed themes? etc?

I cant divine what actions you took … but I can check on my system and /var/lib/sddm is sddm:sddm.
As are all of its contents, except state.conf which is, and it appears should be, owned by root.
I also checked an ISO (silghtly old … from late May) … and there too it is sddm:sddm ownership.

I’ve had this installation for a year and a half, and I very rarely run sudo, but it’s not out of the question that something I ran as root unexpectedly changed files and directories inside /var/lib/sddm.

I just think it’s odd that others ran into this problem, since there are at least three posts about it on this forum, and there’s one on Stack Overflow as well. Surely anybody manually changing ownership would know what they did and fix it without having to ask the Internet for help… :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.