How to switch to Wayland? Wayland does not work

I’m using Manjaro KDE Plasma with X11 and I’d like to switch to Wayland. However, when I choose “wayland” in the SDDM login manager and log in, the screen just goes black and then back to the login manager. Only X11 works.

How can I debug what is going wrong? I have not configured anything special. I believe I only installed wayland.

System:
  Host: saturn Kernel: 5.16.11-2-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.2.0 Desktop: KDE Plasma 5.24.2 Distro: Manjaro Linux base: Arch Linux
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: eVga.com. driver: nvidia
    v: 510.54 bus-ID: 0a:00.0
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: nvidia
    gpu: nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.54 direct render: Yes

This might be of some help:

Thanks. It kind of works. I do get some frequent flickering and cursor issues. I have a few questions:

Is it expected to be better with other (free) drivers? Do I need the same settings (mkinitcpio, grub parameters) for other drivers, too? Does GPU performance decrease with other drivers? The free driver is from 2018 and not updated since? I did:

> mhwd -li
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI

But not sure how to activate the free drivers.

Is Wayland not mature enough or why does it flicker?

I have AMD RX, and I dont have the option to switch X11 to wayland, a newer installation has this option
Can I have this option ?

1 Like

The nouveau driver is blacklisted to prevent people from using it and then getting poor gaming performance.
Most accounts of this issue happening are old but I’m getting flickering issues as well.
Maybe try switching nvidia driver version? 390 and 470 are still kept around iirc. I haven’t tried switching versions myself, so I can’t say if it’ll work.

Aside from that, whether or not this gets fixed is likely between open source devs and nvidia.
See here for some more context about the arise of the issue: https://blog.devgenius.io/wayland-and-nvidia-in-2022-2f0407fb34f4

I think you have to install the plasma-wayland-session package for the option to show up(it got included in the default install recently thats but I think it was removed again).

2 Likes

THAT’S the package I was looking for! :pensive: :+1:t4:

1 Like