How to switch off/on MATE desktop notifications?

mate

#1

Very often I need to take screen recordings, so very important to switch off pop-up notifications globally on desktop and switch on them after recording.
On other DE’s we have panel applets for that, but how to do it on Mate?
I just can not find a convenient solution…


#2

There isn’t one. Remember that MATE is a fork of GNOME 2, so notifications are not handled in the same way as newer DEs with their fancy “notification centre” (you’ll find the same issue with WMs like i3).

What you can do with a dual-monitor setup is override the monitor on which the notifications display.

Otherwise you have to remove the notification daemon, which only half solves the problem.


#3

Thank you…
I’ve found this:

  1. to switch OFF:
sudo mv /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service.disabled
  1. to switch ON:
sudo mv /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service.disabled /usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service

It works but is it possible somehow to do it without entering password via launcher?


#4

Hmm… if this is tied into dbus you should be able to send a message to your own dbus session.

Edit: Yeah, no, you can send a message and it will be displayed. You can’t disable notifications via dbus.


closed #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.