How to switch from NVIDIA to AMD GPU (both stay in the same system)

Are the free driver installed?

mhwd -li

@megavolt output of mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

but… should be:

blacklist nouveau

nouveau = Name of free driver (… sorry :smiley:)

Remove this

from the the kernel parameter. :slight_smile:

No change :frowning:

cough how would one remove nomodeset from the kernel parameters?

In /etc/default/grub remove it and then sudo update-grub.

should I change

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 nomodeset"


GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
1 Like

No change in behavior :frowning:

So these files does not exist correct? at least in xorg.conf.d/ there should be only 00-keyboard.conf

currently just that and the 20-radeon.conf suggested earlier

xorg.conf exists:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 450.80.02

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.100

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic XG2402 SERIES"
    HorizSync       160.0 - 160.0
    VertRefresh     48.0 - 146.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device1"
    Driver         "vesa"
    VendorName     "AMD"
    BoardName      "RX 580"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DP-0: 1920x1080_144 +1920+0, DVI-D-0: nvidia-auto-select +0+0, HDMI-0: 1920x1080 +3840+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "On"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

R-E-M-O-V-E :crazy_face:

I am not mad… the conversation is just very fast for a forum where you have to think… xD

LOL, I’m still a lamb… okay I removed both /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/20-radeon.conf and NOW IT WORKS!!!

thanks @megavolt <3

p.s. for others like me (very naive) you can, from the command line / ssh do the following for easier debugging

sudo su // enter super user state
xinit // which logs to /etc/logs/Xorg.0.log

Btw… LOL … here is the problem… You used nvidia options with the amd gpu… no wonder it does not work xD On top you used vesa as driver… it is a generic driver for every gpu with very basic functionality… means only the terminal :stuck_out_tongue:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.