How to restore the system step by step after unseccessful update?

Hi.
My Manjaro has been notifing me about updates for 3-4 days, but when I tried to update I got an error, and pamaс shut down, neither the command line nor graphically. And then I decided to update in batches. I unchecked all packages in pamac and updated in 3-4 iterations. After the reboot, the system did not start up, it is now frozen at the loading stage:

[FAILED] Failed to start Light Dispaly Manager
See 'systemctl ststus lightdm.service' for details.
[ OK ] Started Network Manager Wait Online
[ OK ] Reached terget Network is Online
Startting CUPS Scheduler…
[ OK ] Started CUPS Scheduler

That's all.

Guys how to restore the system step by step? I need to pass the project, and the working computer is dead :frowning:

Ideally, you made a timeshift snaphot before the update (or had timeshift take snapshots automatically).

If that is the case, restoring it is a matter of booting to a TTY (or a live image+chroot), and then running sudo timeshift --restore and selecting the most recent snapshot before the update.

If you haven't done that prior to the update, the issue is a bit more complicated. There is no single general "reset to factory defaults" button. You are probably in a partial update state. Can you log into a TTY? If not, you'll have to boot from a live image and chroot.

Then, the simplest thing you can try is sudo pacman -Syyuu, but that might not work.

You probably mean Pamac, not pacman.

Things like these are the reason I don't use Pamac for updating and always log off, switch to TTY2 and update with pacman -Syu.

It looks like system booted but not to graphical interface. Press ctrl+alt+F2 or F3 the login in TTY and try to finish update there.

Thanks for a reply!

I loged into TTY and made sudo pacman -Syu and it's the same frozen stage.

So I tried:

  1. sudo pacman -Syyuu - and it stops with an error - failed to complete the transaction (invalid or corrupted package) - what packege it doesn't say
  2. tried to diasble LightDM and install GDM - and the same - instalation stops with failed to complete the transaction (invalid or corrupted package)
  3. sudo pacman-key --refresh-keys
    sudo pacman-key --populate archlinux manjaro
    sudo pacman -Syyuu
  4. sudo pacman-mirrors --country Russia,Germany,France,Austria

And after all pacman -Syyuu

And all the same error - failed to complete the transaction (invalid or corrupted package)

Are any ideas how to fix it?

Generally, the best idea is to do a search and see if other people have encountered the same issue, and then try out the suggested solutions. Or search for ''majaro failed update'', or ''manjaro interrupted update'', or similar. For example, a search here brings up this result in the tutorial section.

To complete the update, you need to clear the pacman cache: pacman -Sc

1 Like

Oh man, thank you! It really helped
+100 to your carma

Forum kindly sponsored by