How to reinstall kernel and fix boot issue

Basically, my original problem was that whenever I tried to boot I would get

error: file ‘/boot/vmlinuz-5.15-X86-64’ not found you need to load the kernel first.

In the course of trying to fix this it appears I have broken it further to where in the Manjaro boot screen I do not even have to option to attempt to use a kernel, it displays only my Windows 10 drive and the Memory Tester (along with the grub command line and boot settings). I followed instructions mostly from this thread. I have tried to use pacman -Syu to see if that would fix anything but it prompts me with a thousand “replace x with y? y/n” (package and package5, usually) and no matter what I do I end up with unresolvable package conflicts and no transaction happening.
Usually, I would just move on and reinstall, but there are a few important files I need.

Thank you.

Sounds like you just missed some of the recent announcements…

You do want to do those replacements (plasma changes for kde6)…

The rest is one of the things mentioned here

So start with sudo pacman -Syuu and go from there.

Include actual output or we cant really help.

Other things that might be helpful in case you need them …