How to make titlebars blurry in Plasma?

I noticed on various videos and screenshots that semi-transparent titlebars (aurorae themes) are often blurry. I am not getting it (I get transparency without blur on titlebar) which is causing mismatch between window which is blurry and titlebar (which is won’t) even if the titlebar is from the same global theme (theme family), so they should match.

Here is the aurorae theme that should match the Kvantum theme:

When I replace it with non-transparent version, I get this:

None of these are ideal. The lack of blur in the semi-transparent version makes it less readable.

Any idea how to fix it?

Hi @michaldybczak,

Have a look where the effect is set, for a drop-shadow on the text.

I doubt it will, but I hope it helps!

I’m not following. The aurorae have not many options, just the size of the buttons and there is global window frame size. Nothing more, so I have no idea what are you talking about.

I only thought to mention that it’s a drop-shadow that helps. I have no idea where you set it.

Except maybe…AFAIK the title bar text style is part of the theme. So I think if you want this you need to either:

  1. Use a theme styled as such; or
  2. set a window rule to do this.

I still don’t know what “drop-shadow” is.

AH, well, it’s the name of the effect. An example:


It’ll help make the text readable on a translucent background.


@michaldybczak I think the blur on the titlebar is controlled by

  • System Settings > Workspace Behaviour > Desktop Effects > Appearance > Blur
1 Like

I already have blur enabled in Desktop Effects. This is why I’m confused why titlebars aren’t blurred and thought there might be some other setting.

I checked my test user with vanilla settings and when I used semi-transparent aurorae, it wasn’t blurred, although blur is enabled in desktop effects. So this is not a matter of user config. Something is missing? Or maybe that is how it works and that is normal and one needs to have special blurred aurorae theme?

In my case with a certain aurorae theme the titlebar is blurred when I use the desktop effect and transparent when the desktop effect is turned off.

I am not sure but I guess you will have take a look into the decorations.svg of /home/USER/.local/share/aurorae/themes/Yourauroraetheme/decoration.svg. Open with text editor.

E.g. You can try Wings-Blur-Dark or Wings-Blur-Light and compare with the one you want to use.

I tried Wings-Blur-Light and… it flickers between solid and semi-tarnsparent… This is seriously bugged.

Maybe this is a Wayland session issue?

There is no flickering with Wings-Blur-Light on my side, neither with X11 nor with Wayland. Quite solid.

Though it required me a new logon after applying the aurorae theme to get the buttons on top properly.

Edit and correction: Indeed, buttons disappear when multiple windows are open and maximized from restored state with Wayland. This does not happen on X11.

Edit 2: Tried other aurorae themes and it’s the same. Some issue with proper scaling. Wayland specific.

I’m not sure how they work, but it’s not tasty like window blurring - here’s an example with Konsole with Dracula theming set for full transparency.

I do, indeed, get blur - but it doesn’t blur the layer beneath the window, rather the desktop… so there are surely issues with decoration coding and interaction with desktops (X11 here).

Whilst the Window blurs it’s immediate background, the Material (with LIM) decoration blurs the wallpaper and displays it on top of the dark window beneath.

Breeze (LIM) is more primitive, background windows have blur (again, brings wallpaper to the top) but not the active windows…

In the end, I just go with opaque - and match the colour (Konsole lets me buck that trend - so it stays Dracula…