How to make the manjaro auto login the i3 wm when enter the desktop?

I use manjaro and enter the KDE by default .

I check this link i3 (简体中文) - ArchWiki

And add exec i3 into the .xinitrc file. But still the manjaro enter KDE. How to change it?

Hi. Check what Display Manager (LightDM, SDDM and so on) you use. Then follow instructions for that DM, for example:
https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin
https://wiki.archlinux.org/index.php/SDDM#Autologin

EDIT. .xinitrc is used if you do not have any DM.

thank you for your reply.
I check the link. I use sddm. I found available in the dir /usr/share/xsessions/

and create a file.

/etc/sddm.conf.d/autologin.conf

[Autologin]
User=xxx
Session=i3.desktop

But still enter KDE not i3. How this happen?

I don’t use either sddm or i3 so I don’t have experience with them. Maybe someone else could give advice about that issue.

I use autologin to tty without DM and then my WM starts from .xinitrc.

OK done. Related setting is here. search for the login in the settings.
t|690x334

1 Like