How to install Manjaro from an ISO with outdated keys

I just wonder, what the way would be for a fresh-install. I am currently setting up my laptop via manjaro-architect. However during the installation always fails due to the invalidated keys of Helmut. I guess, I just have to wait until this is solved in upstream? That is rather frustrating.

It should be resolved already in the latest downloads on the download page.

Please feed back if that would not be the case…


It’s long but there is an option in Architect to rebuild the pacman keys.


I downloaded manjaro-kde-21.0.7-210614-linux510.iso today. This is still the current version.
When installing pacman -Syuu manjaro-architect, it also grabs the latest keyrings for arch and manjaro - at least for the live system and upgrades the whole live-system.

When going through the architect, including “Refresh Pacman Keys”, I got a lot of gpg errors (“gpg: error reading key: no data” and “gpg: error retrieving key XYZ via WKD”) here earlier this day and refreshing the keys took like 1+ minutes.
In fact, it turned out, that this was caused by me doing a full upgrade of the live-system and the failed key-refresh resulted in my problems.

When I now just install pacman -Sy manjaro-architect and run the architect, the error disappears. So it was just a PEBKAC-error.
So consider my previous complain as void.

Just in case, you can also go to the #announcements and guess what?

and use that instead for now and switch to the stable branch once it gets released.


Try this… :arrow_down:

rm -v /var/cache/pacman/pkg/*.sig
rm -r /etc/pacman.d/gnupg
pacman-key --init
pacman-key --populate manjaro
pacman-key --populate archlinux
pacman -Syvv
1 Like

I’ve moved this from that thread as OP was specifically asking for new installs form a dowloaded ISO.


1 Like

Thank you for moving the topic.
I ran into further trouble now. Basically it is a mixture of “manjaro-architect” being sort of in a stale development state and the invalidated key of Helmut Stult.

I previously thought, just installing manjaro-architect on the latest KDE image via pacman -Sy manjaro-architect and without upgrading the live-system works. However, this is not (always) the case.
It turns out, that if the packages in the live-system are not up-to-date, the installation profiles might cause manjaro-architect to fail. In fact, the result is, that there is either no profile for a desktop environment selectable (it just skips it) or sometimes there is just a limited set (I had kde-minimal sometimes available and sometimes not).

I figured, that this is because manjaro-architect seems to check /usr/share/manjaro-architect/profiles upon start and deletes profiles, which conflict with the live-systems repo.

So I turned back to my previous way of doing it: “Upgrading the live-system before running manjaro-architect”.

pacman -Syuu manjaro-architect
# For rebuilding keyring, I also had to stop / start pacman-init to reduce gpg version mismatch errors
systemctl stop pacman-init
rm -rf /etc/pacman.d/gnupg/*
rm /var/cache/pacman/pkg/*.sig
systemctl start pacman-init
pacman-key --init
pacman-key --populate archlinux manjaro
pacman-key --refresh-keys

I then also reaquired all installation profiles, just to make sure everything is in order

rm -rf /usr/share/manjaro-architect/profiles
git clone /usr/share/manjaro-architect/profiles

With this configuration, I finally had a huge list of desktop environments to chose from. So I expected this to be the way. However, the invalid key of Helmut Stult not struck again:

This is super frustrarting, as of right now, manjaro-architect does not seem to allow me to properly install the system for one thing or the other.

You shouldn’t refresh the keys.

1 Like

I just figures the same in a trial and error process :slight_smile:

Thank you!

Upgrade live-system, install manjaro-architect, rebuild keyring from manjaro-keyring and archlinux-keyring repo package and do not Refresh Pacman Keys.

sudo pacman -Syuu manjaro-architect
# For rebuilding keyring, I also had to stop / start pacman-init to reduce gpg version mismatch errors
sudo systemctl stop pacman-init
sudo rm -rf /etc/pacman.d/gnupg/*
sudo rm /var/cache/pacman/pkg/*.sig
sudo systemctl start pacman-init
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro

Troubleshooting manjaro-architect
And in case, if there is no desktop environment selectable on manjaro-architect (e.g. when having it run before the steps above).

sudo rm -rf /usr/share/manjaro-architect/profiles
sudo git clone /usr/share/manjaro-architect/profiles
1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.