How to install anbox on manjaro?

Update to the latest kernel from the kernel manager. and try again.

installed 5.9.8-2

zgrep -i -e android -e ashmem /proc/config.gz
# Android
CONFIG_ASHMEM=y
# end of Android
# Android
CONFIG_ANDROID=y
CONFIG_ANDROID_BINDER_IPC=y
CONFIG_ANDROID_BINDERFS=y
CONFIG_ANDROID_BINDER_DEVICES="binder,hwbinder,vndbinder"
# CONFIG_ANDROID_BINDER_IPC_SELFTEST is not set
# end of Android

it worked after i ran

mkdir /dev/binderfs
mount -t binder binder /dev/binderfs

Thanks alot

I can’t install on manjaro with the anbox-git package. can you help?

In the kernel 5.10.2 Anbox isn’t working. You should either wait until the stable branch gets the kernel update or switch to testing branch.

1 Like

I’m on linux 5.9

Even in that Anbox isn’t working. As I tested, it worked in 5.10.4

so can I just switch to testing branch,update the kernel and switchback to stable branch?

No, if you switch back to stable branch the kernel will get downgraded to the current one.

when do you think we’ll have that kernel in stable branch?

Now 5.11 is under testing, so 5.10’s later version should be available soon. Because of rolling release the update should be as soon as possible.

I’m now on 5.10.7 but it’s still not working.
when try to launch it crashed and the error log is
[ 2021-01-23 05:19:42] [daemon.cpp:61@Run] [org.freedesktop.DBus.Error.ServiceUnknown] The name org.anbox was not provided by any .service files

when try to do modprobe -a binder-linux ashem-linux

it gives error report
modprobe: WARNING: Module binder-linux not found in directory /lib/modules/5.10.7-3-MANJARO modprobe: WARNING: Module ashem-linux not found in directory /lib/modules/5.10.7-3-MANJARO
@SameExpert

Instead of this, do this:

It seems that the kernel itself loads ashmem but not binder, so mounting binderfs works for me.
Also don’t forget following these steps.

Follow this if you haven’t yet.

1 Like

@SameExpert
so I have to perform the mkdir and mount step everytime I boot and now anbox is working
but there is no internet inside anbox
I tried
sudo systemctl start systemd-networkd
but no results

in a post above shows how to add to fstab

Disable systemd and use network manager, how to is posted in the arch wiki link above

what’s fstab? and which post?
I can’t find it

It’s a file located in /etc folder.

/etc/fstab automounts for you everytime you boot your PC. Open it, add this line at the end and save it:

binder                       /dev/binderfs binder   nofail  0      0

That’s because systemd-networkd should start before anbox-container-manager, but you have already started anbox-container-manager. So you should stop anbox container manager:

sudo systemctl stop anbox-container-manager

You should also enable systemd-networkd and anbox-container-manager so that you don’t need to start it everytime, by:

sudo systemctl enable systemd-networkd anbox-container-manager

still internet not working

@SameExpert

I directly copied/pasted this code
$ nmcli con add type bridge ifname anbox0 -- connection.id anbox-net ipv4.method shared ipv4.addresses 192.168.250.1/24
from archwiki
but it’s still not working.
Did I need to change any parameters?

It should work. Try rebooting you PC.

[Make sure you have done these steps properly]:

This is what I typed after rebooting my PC and anbox launched successfully.

riyango@cosmoblaze ~> sudo systemctl enable systemd-networkd anbox-container-manager

[sudo] password for riyango: 

Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-networkd.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-networkd.socket → /usr/lib/systemd/system/systemd-networkd.socket.
Created symlink /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service → /usr/lib/systemd/system/systemd-networkd-wait-online.service.

riyango@cosmoblaze ~> sudo systemctl start systemd-networkd anbox-container-manager

riyango@cosmoblaze ~> anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity`

But there is still no internet