How to improve Manjaro Fonts rendering

What about a script to revert back if this doesn’t go right or the user prefers the default font setup?

Dear @leemaster81, the script is just able to resume the old settings. Just run it again and it will ask if you want UNINSTALL it, that’s all! :slight_smile:

OK, well in that case I will give it a go tomorrow. If anything, I can just recover from a system image.

@joined, @Odysseus thanks for the great work!

I wonder: did anyone here get Monaco to render nicely? Yes, I know, there are many other good looking monospace fonts :wink: I think this font is still one of the best, but is notoriously hard to get right under linux. Especially when using any of the JetBrain editors (Webstorm/Phpstorm/Pycharm/etc).

Second question: does changing font engine have any impact on general (graphic) perfomance?

Thanks.

1 Like

@sender, I haven’t done any specific benchmark to test the performances but from my daily using I don’t see any delay. :slight_smile:

PS: happy to have helped you! :wink:

I thought font rendering depends on the DE settings and DPI and monitor resolution. Am I wrong this whole time?

@crazyg4merz, I think Infinality Engine overwrite some of the DE settings.

1 Like

@joined Can you explain the following:

On https://wiki.archlinux.org/index.php/Infinality It says:

Force Slight Hinting: Force slight hinting even when programs want full hinting.

So clearly slight hinting is the preferred modus. But down that page (https://wiki.archlinux.org/index.php/Infinality#Xft_and_FreeType_settings) it says:

Settings should duplicate those found in the Xft configuration file (/etc/X11/xinit/xinitrc.d/xft-settings.sh):

Xft.antialias: 1
Xft.autohint: 0
Xft.dpi: 96
Xft.hinting: 1
Xft.hintstyle: hintfull
Xft.lcdfilter: lcddefault
Xft.rgba: rgb

Should I set mate font config settings to slight or full? Thanks.

@sender, I suggest slight hinting with Infinality.
Also, Monaco font looks good here with hintslight.

Thanks for the reply. Are you also using Monaco in a Jetbrains editor?

No, I use Monaco in xfce-terminal and in gedit. Looks good to me, but not all font sizes look good. I think I have it set to 12.

However, I rarely start xfce4. It’s mostly i3 with urxvt terminal and Terminus font.

I tried it and it really improves font rendering and readability considerably. Thanks!

So far I have no problems with speed or stability (KDE plasma shell).

@sender, from my little experience seems as Infinality use only Slight Hinting (isn’t important as you set your DE preferences, at least on XFCE).

@torvic, happy to have helped! :slight_smile:

do l have to rerun this script after the incoming 2016.07.19 stable update?

After reading the at the script, I see that what it does is adding a custom repository into your system and install the file then add in a config file into your system. So you don’t need to rerun it I think. :slight_smile:
@joined I think you need to post what you’re doing with the script and inform the users that this script will add a custom repository into their system and install some packages. Because they need to know the risk of adding custom repository even though it seems harmless.

http://bit.io/manopt is unreachable here

I downloaded it before posting my last post here. So it was working here.
Edit: you put in the wrong link. It’s http://bit.do/manopt2

The original link is: http://bit.do/manopt
@crazyg4merz, I just did this in the 3th post! :slight_smile:

1 Like

Okay, sorry I just read the first and last post :slight_smile:

My fonts.conf, from /home/username/.config/fontconfig. I’ve used it for quite some time across DE/WMs and Arch & Debian distributions.

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
 <dir>~/.fonts</dir>
</fontconfig>
3 Likes

Forum kindly sponsored by Bytemark