How to ignore update packages of AUR

update
yaourt

#1

Hello, I have some packages installed from AUR, and I don’t want to update them(ttf-win10). So is there a way to ignore it when I use yaourt -Syua?


#2

Hi again Vamposine,

This can be easily accomplished. I am running XFCE, so please replace ‘mousepad’ with your text editor of choice

sudo mousepad /etc/pacman.conf

Find the line (27) containing “#IgnorePkg

and uncomment the line and add package to make it look like

IgnorePkg = package-name

and save.

Then run

yaourt -Syyua

(extra y forces resync with servers and is advisable :wink: )

PS - using pacaur, you dont need sudo the extra ‘a’ and it will inform you of IgnorePkg
pacaur -Syyu


Check for updates from AUR - enabled or disabled?
#3

THANKS!!:grin:


#4

One more question, after I set as ignore, but in Octopi, it always prompts there is update.

But when I run yaourt -Syua, it said they are ignored.


#5

Odd. Should work. I found some old bug reports of it being problematic like this one


but that was fixed a bit ago.


#6

you can also use

yaourt -Syua --ignore package-name

if you want to ignore all updates for PKGBUILD files in the AUR, do one of the following commands:

yaourt -Syu
sudo pacman -Syu

i do not use pamac or octopi, so i cannot help you with them.


#7

Why man yaourt says nothing of the -y option?

$ man yaourt | grep '\-y' $


#8

the -y option is part of yaourt’s features. it is pacman’s feature. yaourt only passes this argument to pacman.

therefore, you have to look for it in “man pacman”.


#9

I see. Thanks.


#10

I tried and this is my result with 1 manjaro package and 1 AUR package in my ignore list.

Octopi notifier:

  • It don’t tell me anything (no updates needed)

Octopi:

  • It don’t show me the AUR package as outdated :worried:
  • It show me the manjaro package as outdated, but the upgrade button is disabled. This is a nice way to function as we can see there is an outdated package and remind that it is ignored. I’d love it could do the same for the AUR package.

#11

@cscs Here I set the ignore packages.

➜  ~ yaourt -Syua
[sudo] password for zhengshuai: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 infinality-bundle is up to date
 infinality-bundle-multilib is up to date
 infinality-bundle-fonts is up to date
 ttf-ms-win10:  (ignoring package upgrade)
 ttf-ms-win10-japanese:  (ignoring package upgrade)
 ttf-ms-win10-korean:  (ignoring package upgrade)
 ttf-ms-win10-other:  (ignoring package upgrade)
 ttf-ms-win10-sea:  (ignoring package upgrade)
 ttf-ms-win10-thai:  (ignoring package upgrade)
 ttf-ms-win10-zh_cn:  (ignoring package upgrade)
 ttf-ms-win10-zh_tw:  (ignoring package upgrade)
 Foreign packages: | 60 / 60

But in the Octopi, it still mark as outdate


#12

I dont use octopi, and am not at a Manjaro machine right now. It seems you’ve set them correctly. I suppose my next question would be if those packages would indeed be updated by octopi’s full-update. Or does it even update aur packages by default ? (And therefore you would be selecting them manually anyways?) I hope someone else has more answers for you. I would say just come on over to the dark[+green text] side. But thats not the solution you are looking for.


#13

I suppose that octopi will update all the packages include AUR when do a full-update.


#14

Octopi don’t update AUR package. it just show them as outdated.
It need a manual update for each package.


#15

No, I’m sure that I could use Octopi to update the AUR packqges


#16

Octopi won’t update automatically AUR packages. it will only show there is outdated AUR packages.

You can update all AUR packages at once by clicking the red alien button on the status bar (bottom of octopi).

smargit is outdated but the upgrade button is disabled.

smartgit is outdated but no upgrade option in octopi notifier

firefox-kde (manjaro) and smartgit (AUR) is outdated, but only firefox-kde will be upgraded with the “upgrade option”.


closed #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.