How to get rid of start job waiting for deleting swap partition?

I had to delete my encrypted Swap partition while solving some issues in chroot.

Now that I can boot back into Manjaro, I don’t need this partition back, but the problem is that loading the system takes and additonal 1:30 min as there’s

A start job is running for /dev/disk/by-uuid/<my-deleted-swap-partition>

which is pretty annoying. How can I get rid of this?

I already edited /etc/fstab and removed the reference to my deleted swap partition UUID there, but the start job is still running every time.

I found that there’s another reference to the deleted partitoin’s old UUID in /etc/openswap.conf:

## cryptsetup open $swap_device $crypt_swap_name
## get uuid using e.g. lsblk -f

## one can optionally provide a keyfile device and path on this device
## to the keyfile

## additional arguments are given to mount for keyfile_device
## has to start with --options (if so desired)

## additional arguments are given to cryptsetup
## --allow-discards options is desired in case swap is on SSD partition
cryptsetup_options="--type luks"

Can I just delete this file? I didn’t really find anything about it. I do not assume this alone would solve the issue though. How can I identify which part of systemd is responsible? What other references could there be that I should clean up? I already searched /etc/systemd for the UUID but it didn’t reveal anything. Thank you for any insights :bowing_man:

Pacman actually tells me that I’ve got mkinitcpio-openswap 0.1.0-3 and I found a mention of the file in question on its AUR page :thinking: The package description says

mkinitcpio hook to open swap at boot time

Would the right course of action be to just uninstall this package or did it come with Manjaro? I don’t think I’ve installed this myself, but I could be wrong of course.

@dm-on Please read this:

Thank you Megavolt. Sounds to me like I could just remove both openswap resume hooks from /etc/mkinitcpio.conf and run mkinitcpio -P to ensure the change wille be in effect for booting with any installed kernel.
Furthermore, it should be save to uninstall mkinitcpio-openswap and remove /etc/openswap.conf. I should probably update my grub configs to remove resume as well.

I never really used hybernation, only suspesion, so all of this should be save.

Did I miss anything?