How to get Redshift to work in deepin desktop

Redshift can't find location in deepin desktop.

[davek@optiplex ~]$ redshift
Trying location provider `geoclue2'...
Using provider `geoclue2'.
Using method `randr'.
Waiting for initial location to become available...

How do I correct this?

The following might help:
Open a terminal and run

sudo nano /etc/geoclue/geoclue.conf

Use the arrow keys to navigate to the following line:

#url=https://location.services.mozilla.com/v1/geolocate?key=YOUR_KEY

Uncomment it (delete the #) and change YOUR_KEY to geoclue

Press Ctrl-o, Enter and Ctrl-x to exit nano. Run redshift again.

i had the same after the latest manjaro set of updates and the way i worked around it is as follows from previous issue reported:

torvic9's manual solution works a treat (unless you move time zones alot). for lat and longtitude, just use google maps or similar for your location. Although in addition, i did remove redshift then reinstall it via pamac. After thats all done, its a good idea to turn off night shift in the control centre and just use redshift from the launcher (with autostart ticked) otherwise the screen might flicker between "normal" and "night" when the sun goes down.

Forum kindly sponsored by