How to get better font rendering?

I’m running XFCE, and the system font doesn’t look great. It’s as if anti-aliasing isn’t working. I tried the instructions outlined here, but it did nothing to solve the problem.

Are there other ways to improve font rendering on Manjaro? Thank you.

P.S. Some examples:

Did you already try to adapt it via
xfce4-settings-manager → Appearance → the Fonts Tab

1 Like

I’m using the Inter font regular with full hinting, that’s what did it for me. I’m on KDE though.

1 Like

I don’t know about that one, but I find Roboto renders very nicely on my TV… it is also least affected by different ‘hinting’ settings from none to Full…

1 Like

For me, with both KDE and Xfce, low hinting has brought success. Full hinting makes the font display rather unclean.

1 Like

Yes, I attempted changing the anti-aliasing settings there (none to slight to full). That didn’t work for me :frowning:

These pictures look like your monitor is attached to the computer via a VGA cable, using analog signals.
If there is no possibility to switch to a digital connection, such as DVI, HDMI or DisplayPort, I’d first recommend adjusting your screen.
Most monitors come with an Auto Config feature to automatically adjust for best quality when using VGA. Please refer to your monitor’s manual.
Alternatively, you can play with picture settings, such as “Clock” and “Phase” in order to get the best quality possible.
However, the best solution still would be using a digital signal connection to the monitor.

As using a digital connection does not automatically improve font rendering in all cases and in all programs, I also did a few tweaks in order to improve it: Firefox Nightly 86 and VDPAU / Nvidia - #7 by DAC324

1 Like

Try to install ttf-liberation fonts, it has changed the rendering nicely with browsers, at least.
You can find it in the Manjaro repo

1 Like

Thank you for this wealth of information! Really appreciate it. Unfortunately, I’m just using my laptop. That’s what’s been bothering me. Makes me think if this is related to this. Maybe my installation went out of whack, but something happened that led to fonts looking bad.

Actually, this works great for browser rendering. Why is that? I know it isn’t fixing the system fonts, but for browsers, it does wonders.

Strange, ttf-liberation is already installed by default with Xfce :thinking:

I am not sure, if you only install Firefox as browser, i think you don’t have it by default.

My Xfce installation is a little over a month old now and I did NOT consciously install it, but it is there …

It also comes with Chromium, maybe you have it installed

I do not have Chromium. Anyway, let’s leave it like that …

Yeah, let’s leave it like that :slight_smile:
But i have the clue, ttf-liberation is not included in Minimal xfce Manjaro, probably in the normal version. For some reasons, i installed the lastest stable release this morning in a VM, i checked it).

1 Like

Then, it looks like this might be a good advice:

Means that you may give the kernel 5.4 a try which is the current LTS kernel in Manjaro.