How to fix USB with corrupted partition table

I have this USB stick which is displaying the size in GParted but I’m unable to create a partition table
and getting this error “input/output error during read on /dev/sdb”

Disk /dev/sdb: 14.51 GiB, 15581839360 bytes, 30433280 sectors
Disk model: STORE N GO      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7aa21479

sudo gdisk /dev/sdb output:
GPT fdisk (gdisk) version 1.0.7

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format
typing 'q' if you don't want to convert your MBR partitions
to GPT format!

Command (? for help): w

Final checks complete. About to write GPT data. THIS WILL OVERWRITE EXISTING

Do you want to proceed? (Y/N): y
OK; writing new GUID partition table (GPT) to /dev/sdb.
Problem opening /dev/sdb for reading! Error is 6.
The operation has completed successfully.

The drive is gone…

It can not even read the device…

$ LANG=C errno 6                                                                            ✔ 
ENXIO 6 No such device or address

Thanks. No way this USB can be fixed?
I was trying a couple of online solutions on how to create a bootable windows 10 and this happened, what could have caused the demage?

This topic contains a utility script for formatting your removable USB device

Thanks @linux-aarhus, I’m getting this output:

Caution: invalid backup GPT header, but valid main header; regenerating
backup header from main header.

Warning! Main and backup partition tables differ! Use the 'c' and 'e' options
on the recovery & transformation menu to examine the two tables.

Warning! One or more CRCs don't match. You should repair the disk!
Main header: OK
Backup header: ERROR
Main partition table: OK
Backup partition table: ERROR

ERROR: failed to open '/dev/sdb1' in read-write mode: No such file or directory.

@megavolt && @linux-aarhus update:
I was able to fix it by entering the USB into a windows machine and formating from there
now it works correctly but I still get “The backup GPT table is corrupt, but the primary appears OK, so that will be used.” on GParted, any idea how can I fix that?