How to enable Wayland on Gnome (nvidia)

Hi,

I want to enable Wayland since I’m experiencing significant tearing. I’ve found the “Cant enable wayland” forum post, but don’t know how to enable KMS to check if that’s an option.

Under Layouts, my Wayland session option is also greyed out.

Running Gnome 3.36.5, GeForce GTX 960 proprietary 440xx, kernel 5.7.15-1.

:point_up: That’s why. If the system detects an NVIDIA GPU, it’s disabled as Wayland is not yet stable enough on NVIDIA hardware.

1 Like

Ah, thanks for the prompt reply! Where can I keep tabs on the progress made?

I wouldn’t hold my breath. Nvidia isn’t interested in supporting wayland and since their drivers are closed source, nobody else can do it for them either.
Here is one discussion about it with some interesting links:

There is a possible workaround, but from what I’ve heard, it’s still spotty.

1 Like

Thanks, will give it a read.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.