How to enable pinch to zoom (trackpad) with Libre Wolf flatpak on X11?

Hi there, I just wondered if it’s possible to use pinch to zoom using the trackpad with the librewolf flatpak?

Searching around, it appears I have all settings checked in the about:config page.

I’m not sure if this is an issue with the flatpak version or because I enabled X11 instead of Wayland. Currently I have set the Touche application to use ctrl++ and ctrl± with librewolf but this solution reformats the page which is kind of annoying. The Touche app works great with other apps though.

Any help or pointers to a solution, would be greatly appreciated.

Thanks, Rob