[How To] Enable Hardware Acceleration on Panfrost and Lima devices

How To Enable Hardware Acceleration on Panfrost and Lima devices

KDE Plasma

  1. Install mesa-git and the OpenGLES enabled QT5 packages: sudo pacman -S mesa-git qt5-es2-base qt5-es2-declarative qt5-es2-multimedia
  2. Uninstall the FB Turbo driver: sudo pacman -R xf86-video-fbturbo
  3. Enable hardware rendering by editing /etc/environment and commenting the
    QT_QUICK_RENDERER=software line.
  4. Switch on compositor and enable OpenGL backend in System Settings -> Display -> Compositor
  5. Reboot

es2_info (from mesa-demos package) should now show you using Panfrost or Mali400 as the GL Renderer and OpenGL ES 2.0 as GL Version.

You can run qdbus org.kde.KWin /KWin supportInformation to verify that Kwin is running with OpenGL ES.

XFCE and other GTK desktops

  1. Install mesa-git: sudo pacman -S mesa-git
  2. Uninstall the FB Turbo driver: sudo pacman -R xf86-video-fbturbo-git
  3. Reboot

es2_info (from mesa-demos package) should now show you using Panfrost or Mali400 as the GL Renderer and OpenGL ES 2.0 as GL Version.

However, to get QT apps using OpenGLES too, you need to install qt5-es2-base, qt5-es2-declarative, qt5-es2-multimedia packages as well.

Known issues with Hardware Acceleration

For known issues list, please see the Status of OpenGLES with Panfrost/Lima topic.

7 Likes

I made a little script if someone wants to change from Panfrost to Fbturbo just with 1 click


the only thing the user has to do is: change the Compositor from off to on and from xrender to opengl and vise versa. its just tested for the KDE Edition.

3 Likes

Thanks for this guide. This seemed to have improved performance in some areas. My application menu widget opens with less of a delay and Dolphin launches faster are the first two things I noticed. Nice improvement on my end

1 Like

I have run you bin/bash script and now my system will not boot. It freezes up on the bootsplash screen. I am able to get to a TTY2 desktop. Any help would be greatly appreciated. Thanks.

To clarify, I selected option "1". I said yes to uninstall mesa-git. And then no the the next three. I have booted into TTY2 a few times and attempted the manual steps. Additionally, I have ran the bash script and selected yes to all of the conflict questions. Still no luck. I am stuck on a frozen bootsplash screen.

I also enabled the compositor to on and changed xrender to opengl 2.0 prior to rebooting.

This can happen, just open TTY2 run the script press 1 or 2 what you prefer and answer everything with yes. After that reboot and it should work.

Mostly a reinstall of Mesa will fix the issue.
But running the script again will do the trick, it worked for me every time, just answer everything with yes

I went into TTY2 and ran the script again while answering yes to all of the questions. It worked.

1 Like

Hi, are all the steps still necessary ? I'm using 20.02.1 KDE Plasma.

  • mesa-git is not installed but mesa is.
  • the Qt5 packages are preinstalled
  • xf86-video-fbturbo is not installed
  • /etc/environment does not contain the line to be removed

I changed the compositor as instructed.

On 20.02.1 KDE Plasma edition it's all set up. All you have to do is change the Compositor Backend to OpenGL 2.0.

Awesome, thanks for confirming it :slight_smile:

There is also the OpenGL 3.1 option that works well.

Is this the case (should be able to set compositor to OpenGL) with the PineBook Pro as well? I am asking because I am on 20.02.1 (installed 20.02 and then installed updated packages via package manager). When I set the compositor to OpenGL windows in KDE I have odd font behaviour, windows do not seem to autosize properly (edge fonts partially cut off, font aliasing irregular)and the hotspots for window close/expand/minimize are very slightly off except when full screen. Hoped maybe at worst I just need a clean restart after setting OpenGL compositor, but that did not help. Maybe a clean install of 20.02.1 is required? ...or maybe some tweaks or scripts still need to be executed if on 20.02 and updating to 20.02.1?

@gabeeg I'm writing this from my Pinebook Pro :slight_smile:

I installed 20.02.1 directly though...

Do all fonts look properly aligned and anti-aliased, for example in a PacMan window? Is yours 20.02.01 installed on the eMMC...not that it matters for this issue, just curious.

Actually, the software manager buttons are sometimes slightly off.

This is a known issue. You can get "around" it, by installing gtk3-nocsd instead of regular gtk3.

1 Like

Yep, that worked. Thanks Strit!

Forum kindly sponsored by