How to enable "Disable touchpad when mouse is connected" in xfce4

As the title explains says, i want to enable that option in my xfce4 session. In the Mouse and Touchpad, the option isn’t there. I have cinnamon and plasma installed and both have it installed in their menus, do it need to edit any specific configuration file? Any help is appreciated

inxi -Fazy:

  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
  root=UUID=59c11c55-cdfa-4660-b66a-21721236e744 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Vostro 3590 v: N/A serial: <filter>
  Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0MD5GD v: A00 serial: <filter> UEFI: Dell v: 1.12.0
  date: 04/07/2021
  ID-1: BAT0 charge: 31.8 Wh (92.7%) condition: 34.3/42.0 Wh (81.7%)
  volts: 12.9 min: 11.4 model: SMP DELL VM73297 type: Li-poly serial: <filter>
  status: Charging
  Info: Dual Core model: Intel Core i3-10110U bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12)
  microcode: EA cache: L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 20810
  Speed: 800 MHz min/max: 400/4100 MHz Core speeds (MHz): 1: 800 2: 2307
  3: 1423 4: 1008
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
  bus-ID: 1-6:3 chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell driver: snd_hda_intel
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
  chip-ID: 8086:02c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  vendor: Dell driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:0042
  class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: pan1 state: down mac: <filter>
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
  chip-ID: 0cf3:e009 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Hardware-1: Intel Device driver: ahci v: 3.0 port: 4060 bus-ID: 00:17.0
  chip-ID: 8086:02d7 rev: class-ID: 0104
  Local Storage: total: 931.51 GiB used: 170.48 GiB (18.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: 0D scheme: GPT
  ID-1: / raw-size: 341.8 GiB size: 335.36 GiB (98.12%) used: 27.66 GiB (8.2%)
  fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 293.33 GiB size: 287.66 GiB (98.07%)
  used: 142.83 GiB (49.7%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
  file: /swapfile
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 220 Uptime: 4m wakeups: 1 Memory: 3.69 GiB used: 1.31 GiB (35.5%)
  Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1485
  pacman: 1480 lib: 395 flatpak: 5 Shell: Bash v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

Hi @MaG_NITud3 ,
You can disable the touchpad under settings, then Mouse and Touchpad , see the tab Behaviour and select from the display list the touchpad and press the button on the upper right to disable the effect. I wonder whether you can try and found the correct setting.

Hope this help, regards.

But that isnt what i want, what i want is that the touchpad remain disabled when my mouse is connected and automatically reanables when i disconnect the mouse. This option is present in Plasma, Gnome, Cinnamon, etc. But i cant seem to find it in xfce4.

With this search term thrown at Google:

disable touchpad while mouse plugged in xfce4

the first and subsequent hits all point to an app that is available in the AUR:

AUR (en) - touchpad-indicator-git

Thanks for the help, when i googled it, articles for ubuntu based distros popped up so i didnt look into it further

… anytime!

Lesson learned:
the problems and their solutions are very similar if not the same
across Linux distributions

Just the way to implement the solutions is different between Debian/Ubuntu (for instance) and Arch (Manjaro)
because of slight differences in the naming of tools and system configuration files.

It’s still helpful to have a solution to a problem even though it is not the exact Linux distribution it is described for.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.