How to enable bootsplash with systemd-boot?

I used to have bootsplash enabled in my old system with grub. However, after I reinstalling the system, I chose systemd-boot as my boot loader, as grub had some problem installing on my RAID-1 ESP.
I found many articles about enabling it with grub by adding bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash option to the GRUB_CMDLINE_LINUX_DEFAULT line. Is there equivalent way to add that option to a systemd-boot loader?
By the way, I heard from this thread saying kernel 5.10 doesn’t support bootsplash. However, my old system ran on 5.10 and the bootsplash still worked.


Haven’t tried this myself but probably bootsplash-systemd is what you’re looking for.

Hope that helps :+1: :slightly_smiling_face:

1 Like

I think I find the solution. Installing bootsplash and bootsplash-systemd only does part of the work. After adding the bootsplash-manjaro into hook of mkinitcipo.conf and regenerated the image, we need to add bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash into /boot/loader/entries/manjaro5.10.conf to make it like this

title   Manjaro Linux 5.10
linux   /vmlinuz-5.10-x86_64
initrd  /amd-ucode.img
initrd  /intel-ucode.img
initrd  /initramfs-5.10-x86_64.img
options zfs=zroot/manjaro/root rw bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

Just in case, I executed sdb-manage update (this might not be necessary)
The bootsplash then appears when I reboot the system.
Hope this post help!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.