How to enable analog surround sound?

I recently switched from Mint to Manjaro. Now I have the problem that I cant’ enable surround sound with my Logitech 5.1 speakers. My Mainboard is an MSI H310M PRO-M2 PLUS with Realtek ALC887 sound chip. I remember that this was rather tricky on Mint. This board hasn’t dedicated jacks for surround sound, so first of all I had to reassign the jacks using hdajackretask from alsa-tools. But even alsa-tools are installed, the program doesn’t exist. I used the one from my Mint backup without success. When I try to apply the settings, it gives an error message that it couldn’t write /root/.config/pulse/client.conf.WZMFVO, and indeed there is no pulse directory in the given path.

The confusing fact is that alsamixer shows controls for Surround, Center and LFE, and they are enabled and at 100 percent. But neither the sound settings nor pavucontrol have an option for analog 5.1 audio.
And executing speaker-test -Dplug:surround51 -c6 -l1 -twav only works for front speakers. Center, rear and bass are shown as “unused”.

So how can I turn on surrond sound?

Early surround sound enabled cards had outputs for the different channels.

Logic states that unless you are using a digital output you cannot create surround sound unless you have the corresponding output ports.

What you have done - no matter the distribution - it has been a surrogate surround if it only used a single output channel.

There is a command-line utility to reconfigure the audio codec - hda-verb - that is also included in package alsa-tools. But that would require finding the codec verbs in hex code from a known working system and is not really an option for most users

Suggest you check hdajackretask is installed with

pamac info alsa-tools

and also check the pin ID numbers for the rear jacks that need retasking (Mic and Line)

sudo dmesg | grep snd

No, it is no surrogate. The connectors can be switched to act as input or output. The board is capable of playing up to 7.1. AFAIK under Windows this can be configured using the Realtek utility. Under Linux with Alsa, this can usually be done using hdjackreass. But this tool is apparently not included in recent alsa-tools. Under Mint, after configuring the audio jacks and alsa, the rear speakers, center speaker and subwoofer worked perfectly, and the speaker-test utility gave output on each channel.

1 Like

@nikgnomic, thanks. The pamac info says that hdajackretask is installed, but trying to execute it gives an error unknown command. Typing “whereis hdajackretask” gives nothing. dmesg says Front Mic=0x19, Rear Mic=0x18, Line=0x1a.

Searching for “alsa-tools” via pamac GUI reveals there are 3, non of them seem to be installed by default (in my system)
Looking at the files of all of them, shows /usr/bin/hdajackretask in each, so if you cant find that binary it means you have not installed any of them…

Ah, I see. hdajackretask was listed under optional dependencies. So I installed one of the tools and can now execute hdajackretask. Unfortunately it gives the same error as hdajackretask from my backup regarding the pulse dirrectory.

pamac GUI shows alsa-tools listed with the names of included hardware-specific mixers
but it is still the one package with the same files and dependencies

perhaps you could post the exact error message and it would make more sense

hdajackretask should not be affected by a PulseAudio folder, but it may help to change the PulseAudio profile to for the onboard audio to ‘Off’ so it is not interacting with ALSA

then I suggest you run the utility with sudo and include the full path

sudo /usr/bin/hdajackretask

I already called it using sudo, and did it now including the full path. The error message appears when I press “Apply now”, which is used to test the settings. The message is “Datei ‘/root/.config/pulse/client.conf/G5XOV0’ konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden”, meaning that it couldn’ create the file, because a file or directory was not found.

It can be a tricky getting Apply Now to work by turning off all audio processing
but the changes do not survive system restart anyway
Install boot override usually works ok

Wow, it works now! I was aware that “Apply Now” changes the settings only until next boot, but I thought “Install boot override” would do the same, except that the settings are saved permanent.
In difference to Mint, Analog Surround 5.1 is directly available in the sound settings, without any other changes. I don’t remember exactly the steps I made at the time anyway.
Many thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.