How to do screenshots when PrtSc doesn't work?

I never thought I’d be asking about something this trivial, but Windows had Prt Scr forever and you could just paste image to image editor. Tried it now in Manjaro 21 with KDE Plasma and it did nothing. Downloaded Get Screenshot tool which seems to do nothing at all. What gives? I really like Manjaro 21, but it’s funny that something as trivial as doing a screenshot is so complicated. I need this before I can even post an issue I have with something else lol


I can do screenshots with KDE Plasma by pressing the PrtScr key. It runs Spectacle. Is Spectacle installed on your system?

I recommend FlameShot. However, Spectactle might be the preferred application for KDE.

That said, in this forum is is very discouraged to post screenshots for problems (there are exceptions which might apply to you): [HowTo] post screenshots and links

1 Like

Apparently you’re very new to Linux and/or Manjaro, therefore, please read this:

Also, you never specified whether @mithrial 's solution of FlameShot works or not.

If that fails too, you could try xfce4-screenshooter, a gtk app but worth to try under KDE too.


Right-click the clipboard icon and choose “Configure Clipboard”. Make sure that “Ignore Images” and “Text Selection Only” are unchecked.

In Spectacle, set a delay of a few seconds. Then take the screenshot and immediately open up your application launcher menu. Then just wait until Spectacle takes the screenshot.

It’s not rocket science, but an attitude won’t help you.

Maybe, set delay 3 seconds or more in Spectacle settings.

1 Like

@RejZoR : You made my day. No kidding.

Please try xfce4-screenshooter and you will discover the magic of XFCE :sunglasses:

1 Like

PrtScr doesn’t work at all, I get the app, the app doesn’t work at all. Yeah, it doesn’t work like Windows. In fact it doesn’t work AT ALL. I’m not complaining over you guys, I’m complaining that it doesn’t work.

The issue has been solved since the last update: PrtSc works again!


Re-listed after deleting some posts to ensure anyone else running into the same issue sees the solution. My apologies to the people whose posts were deleted.