How to disable touchscreen on Manjaro GNOME Linux?

Hey! How can I disable touchscreen? (I have a Huawei laptop with a broken screen and the touchscreen glitches out sometimes, and my BIOS has no advanced features)

I have tried the xinput thing and I found out that I have xWayland

I tried disabling it in the conf file, and I can’t figure out how to solve it even temporarily. (if I can figure this out, I will just set up a startup command or something)

I am pretty new to Manjaro and Linux btw. (don’t assume I know things because most probably I don’t)

Huulo and welcome,

I dont use gnome, so I dont know if it has this setting.

An agnostic method may be unloading/blacklisting the module.

lsmod | grep touch

( edit, its not hid_multitouch :sweat_smile: )

To see about blacklisting (persistent):

https://wiki.archlinux.org/title/Kernel_module#Blacklisting

Hey!

This got rid of my touchpad, not touchscreen (oops)

I was lucky to find a mouse :slight_smile:

Edit: The touchscreen still works btw

Hi @apollo_wayne, and welcome!

According to the Arch Wiki:

Wayland/Weston

Wayland does not currently have a known method to lock touching to a specific display in any environment other than sway (or wlroots-based supported compositors). There are tools such as weston-touch-calibrator, but Gnome Wayland uses Xwayland leaving the calibrator unable to locate any touchscreen.

Reading the Arch Wiki on touchscreens
in the introduction
it says:

This article assumes that your touchscreen device is supported by the kernel (e.g. by the usbtouchscreen module).

which leads me to believe that removing that module would inhibit the function.

Whether the module actually has that name or a different one I don’t know.
You could run:
lsmod
and go through the list to see whether a name that appears related to touch is in there
lsmod | grep touch
or
lsmod | grep screen
for example

See if you find something … :man_shrugging:

Thank you!

Somehow I managed to disable it :smiley:

But I have no idea what I did.

I made a conf file and I ran some rmmod commands on HDIs.

No idea.

Now I restarted, then Powered Off → Power On, and now touchscreen is disabled, and touchpad still works.

I have disables some HDI’s and now everything is fine

Thanks everyone!

Then chances are you’ll be back here at some stage. So keep this thread as well as this link as reference:

Perhaps it helps!

2 Likes

You were right…

I have the same problem again :frowning:

Will try that link

My man, you are a genius!

It worked!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.