How to disable the auto lock screen in Manjaro i3wm

When I watch the video on Manjaro i3wm, auto lock screen is a bit annoying, Is there any way to disable auto lock screen and only keep mannual lock screen?

Oke seems your talking about logscreen and not blanking.

Comment out the following line in your i3 config:

exec --no-startup-id xautolock -time 15 -corners 0-0- -cornersize 1000 -locker blurlock

Mine loooks a little different but it’s the line with xautolock.
After saving reload your i3 config with mod+shift+r for the changes to take effect.

1 Like

Hello,

After saving, it’s necessary to logout and login i3, or do “killall xautolock”. If you don’t reboot xautolock stay in memory, so it’s remain active.

In the new i3/config, the line to comment is:
exec --no-startup-id xss-lock --transfer-sleep-lock – i3lock --nofork

Fred

As far as I know reloading your i3config should do the trick. The default button combo to reload the config is mod+shift+r

Or just install caffeine, assuming you have your sys tray active.

Hello,

Yes it’s true mod+shift+r reload i3 config file but don’t kill the software currently loaded. Il you havec(par exemple) nm-applet in your systray it’s remain in the systray. For xautolock it’s same think…

Fred

1 Like

Ah I see. Maybe mod+shift+c is the better option?

# reload the configuration file
bindsym $mod+Shift+c reload

# restart i3 inplace (preserves your layout/session, can be used to upgrade i3)
bindsym $mod+Shift+r restart

If not then yeah logging out and back in or rebooting.

1 Like

I have solved it,
Thank you for your help

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.