How to disable/remove Plymouth?

Hello, I installed several times the latest Gnome iso, first in VM then on a spare partition. As usual, I’ve performed some tweaks to reduce boot time but I failed with Plymouth.

There was no splash entry in /etc/default/grub to delete, I removed plymouth hook from mkinitcpio.conf, no change.
I added splash=off then splash=quiet in grub, nothing…
Of course, I did not forget sudo mkinitcpio -P && sudo update-grub after each try.

After each reboot I could see in systemd logs a Plymouth reboot entry, on each boot Plymouth again, and obviously once logged in systemd-analyze.

I tried to remove Plymouth packages ; as it’s still needed somewhere by gdm/systemd, I fall in TTY at next reboot. After reinstalling them, I can go back in GUI.

As it’s in dual boot with Manjaro KDE, I did not reinstall the bootloader. KDE was listed 1st on grub menu. Maybe my sudo update-grub did not affect the KDE partition controlled grub?
Alright, I forced grub-install on my Gnome partition, no change either.

I don’t know where, in which hidden config of grub/systemd/gdm is stored a Plymouth entry… And how to get rid of it.

Anyway, I ended by using Manjaro Architect and along with other unwanted packages, I removed Plymouth from the list and installed Gnome without it.
A fully functional unstable Gnome without Plymouth.

But TLDR, I’d like to understand where Plymouth is called by systemd/grub/gdm. And how to disable, uninstall it even, without breaking gdm.

1 Like

Moderator edit: Please follow the link, because some steps have changed !


4 or 5 steps are needed to remove Plymouth. They are:

sudo pacman -Rsn plymouth plymouth-theme-manjaro-elegant

1 Like

Yes thank you, but I’ve done all that. I searched on Arch, Manjaro, Ubuntu wikis, Reddit…

I uninstalled the whole dependencies package, though. Plymouth, manjaro-plymouth-theme and gdm-plymouth.

I guess the latter is required by gdm and breaks the GUI if removed.

As I did not have splash in Grub and that I removed Plymouth hook on mkinitcpio, I’d really want to know where it’s required/configured to be launched by systemd.


Thanks to Root tip - do a manual Manjaro installation, Manjaro and Arch wikis, I tried a CLI Manjaro install, then a successful Arch install, the Arch Way (yay!).

I compared the settings too from an installed system from Arch manual installer, Manjaro Architect and Arcolinux (with gdm, sddm then lightdm).

I’ve got a better understanding of systemd services.

Next Gnome install, I’ll retry (maybe) the CLI way, or Architect with customised packages (if it’ll still work then). Or give a try to Gnome minimal iso.

If I’d start from full iso, I’d disable and mask post-install all plymouth related services (there are a few), as well as removing all plymouth/splash entries from mkinitcpio and grub.

Then only I’d uninstall plymouth packages.

My mistake from several weeks ago was to remove plymouth packages without disabling/masking the plymouth systemd services… Needless to say, it did not play well.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.