How to disable monitor mode and return to managed mode?

After enabling the monitor mode using airmon-ng start wlp2s0 (as root), I’m unable to disable it and return back to managed mode.

I’ve tried the following (as root):

ifconfig wlp2s0mon down
iwconfig wlp2s0mon mode managed
ifconfig wlp2s0mon up

But when I checked using ifconfig , wlp2s0 was still showing up as wlp2s0mon , which means it was still in monitor mode.

(Finally, I had to reboot to turn monitor mode off)

Or you could have run airmon-ng stop wlp2s0 to stop it I guess.
You should try it next time, just to make sure. :slight_smile:

1 Like

To disable monitor mode and go back to managed mode, I ran the following:

sudo airmon-ng stop wlp2s0mon

Note: Use mon after the name of the wireless network interface card (since it’s in monitoring mode), else it’ll not work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by