How to delay sound when starting the OS


#1

Hi, I have a problem with my speakers popping/crackling when on the boot phase. I started to experience this problem after I bought an external USB soundcard and new speakers. I get this issue even when booting virtual machines with Linux guests.
It’s annoying and I’m worried it could damage my spearkers and my usb soundcard.

I’ve found a thread on the Linux Mint forum, with a person who seems to have similar problem.
Delaying the start of the audio seems to eliminate the issue.
https://forums.linuxmint.com/viewtopic.php?t=184635

But his instructions do not seem to fit well with Manjaro.
On the first step:

1. edit /etc/pulse/client.conf as root and uncomment the lines:
autospawn = yes
daemon-binary = /usr/bin/pulseaudio
Then change it to “autospawn = no”

In this file in Manjaro those lines are already uncommented, and there are 2 lines with autospawn,one with yes and one with no.

On the second step:
edit /etc/init/alsa-store.conf as root and add these lines right at the end (after exec /usr/sbin/alsactl -E HOME="$ALSACTLHOME" store)
exec /usr/bin/amixer set Master mute >/dev/null
exec /sbin/modprobe -r snd-hda-intel

There’s no /etc/init/alsa-store.conf to edit in manjaro.


#2

This should work

amixer set Master mute >/dev/null
sleep 10
amixer set Master unmute 


#3

On which file should I add that code?


#4

Arch sayes

The system configuration file is /etc/asound.conf, and the per-user configuration file is ~/.asoundrc

Take your pick


#5

an awful lot of work when you can just mute the speaker… :wink:


#6

IIRC there should be a blacklisted PC speaker in modprobe.d

cat /etc/modprobe.d/*.conf | grep pc

#7

You are trying to solve a hardware fault with software - very difficult to do. IMHO that USB soundcard is faulty and you should return it or replace it. It obviously does not have proper filtering and is amplifying electronic noise from your computer during startup.


#8

agree that, but not that anything is faulty.
lots of audio devices can be noisy when first powered up

startup noise for electronics is common problem that pre-dates digital age
noise probably occurs before any software command could be parsed to prevent it

IMO trying to software mute Pulseaudio or ALSA in startup won’t work at all
Muting before shutdown would be better approach, but i can think of couple of reasons why that would be an unreliable solution at best.

There is a simple solution that has worked for decades
people who spend very large sums of money on audio gear swear by it

AWAYS turn on power to amplifer last. ALWAYS turn off amplifier first

if you want to be completely sure, there may be a manual interface device marked ‘volume’ that can be rotated fully anti-clockwise for maximum noise reduction


#9

you could probably do this using a systemd service that disables that usb sound card before sleep/suspend and also one that has a delay after logging in the desktop environment before turning it back on. just an idea, i know there are threads here on manjaro forum and arch wiki about writing systemd services