How to correct some apps improperly themed?

Like Manjaro Settings, for instance.

MSM is rewritten as we speak, so most of the present issues will no longer be there when is released. The current one and the Kvantum themes are not capable to connect with each other due to the adoption of qgnomeplatform and because qt5ct was replaced with it. Some of the elements fallback to adwaita-qt theme.

https://wiki.archlinux.org/index.php/Uniform_look_for_Qt_and_GTK_applications#Qt_apps_run_on_GNOME_Wayland_have_a_non-matching_window_decoration_look,_even_after_setting_a_Qt_theme

Also explains that will only work with adwaita
Still looking for a better approach for all this.

Use the Kvantum Manager, select the theme you want and the theme will change for all Qt apps

Kvantum manager (and other apps too) show the same issue.

My envirorment variable is correctly set to QT_QPA_PLATFORMTHEME='gnome'

Could you tell me how to do this? I’ve tried poking around but I’m at a loss.

Kvanftum can be a bit unintuitive. Press Change/Delete theme, select a theme from drop down menu and click apply.

If you are using matcha-dark-sea, you probably want to use matchama-dark.

1 Like

I don’t think that is the issue here. On a older install, even with the Kvantum from git where some things got fixed, still there are windows/assets that do not follow the theme:

Arc-Dark

Matchama-Dark

and even with Matcha-Dark

So, when selecting Locale or Languages for instance in MSM, the same issue appears

That is a sign that some definitions of the window elements are missing and is falling back to adwaita-qt5. Not sure why is picking the dark one tho …

@radumitrescu - you are doing nothing wrong here. :slight_smile:

@Chrysostomus - i mentioned about this in our channel that something is off. Back then the windows would render white, and some of the text was not visible.

image

It got fixed by this

The problem now is a bit different. Only by using light themes everywhere is working.

Thank you.

It was actually really easy. I just chose KvAdwaitaDarkMaia and now all apps are themed correctly.

My OCD is so very grateful.

1 Like

Right, so you are not using dark theme then … :slight_smile:
Glad you sort it out.

@Chrysostomus - i still think we need to find a proper solution for the dark themes.

I am using a dark theme.

Then i will have to check what is different on my end, because, as shown above, the issue is still present on this particular install when using dark themes. :slight_smile:

And the issue is new. I have been using the very same setup for the last few months and this issue was not present before.

When you have time, and if you want, can i take a look at:
cat ~/.profile
cat ~/.config/qt5ct/qt5ct.conf
cat ~/.config/Trolltech.conf
cat /etc/xdg/Trolltech.conf - this might not exist tho
cat /etc/environment
?
To me it doesn’t make sense what is going on …Because i use Adwaita by default for me was not obvious, hence i tested on another install and the issue is still present no matter what. I will try a new install from the latest ISO too, but that will be later this evening.

export MANGOHUD=1

[Appearance]
color_scheme_path=
custom_palette=false
icon_theme=Papirus-Dark-Maia
style=kvantum

[Fonts]
fixed=@Variant(\0\0\0@\0\0\0\x12\0\x43\0\x61\0n\0t\0\x61\0r\0\x65\0l\0l@$\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0\x32\x10)
general=@Variant(\0\0\0@\0\0\0\x12\0\x43\0\x61\0n\0t\0\x61\0r\0\x65\0l\0l@$\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0\x32\x10)

[Interface]
activate_item_on_single_click=1
buttonbox_layout=0
cursor_flash_time=1000
dialog_buttons_have_icons=1
double_click_interval=400
gui_effects=@Invalid()
menus_have_icons=true
stylesheets=@Invalid()
toolbutton_style=4
wheel_scroll_lines=3

[SettingsWindow]
geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\x1\x9a\0\0\0\x80\0\0\x3\xd6\0\0\x2\xff\0\0\x1\x9a\0\0\0\xa2\0\0\x3\xd6\0\0\x2\xff\0\0\0\0\0\0\0\0\x5V)

[Qt] style=GTK+

cat: /etc/xdg/Trolltech.conf: No such file or directory

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#

QT_AUTO_SCREEN_SCALE_FACTOR=1

QT_QPA_PLATFORMTHEME="gnome"

QT_STYLE_OVERRIDE="kvantum"

# Force to use Xwayland backend
# QT_QPA_PLATFORM=xcb

#Not tested: this should disable window decorations
# QT_WAYLAND_DISABLE_WINDOWDECORATION=1

EDITOR=/usr/bin/nano
1 Like

Thanks a lot! Indeed that clarifies some things for me, and as i estimated, you still might have the qt5ct installed and functional, in spite of the qgnomeplatform being installed too and having that environment variable.
On my end, since i removed the qt5ct dark themes fail to render properly and have that adwaita color background on some elements. Will point that to our team.
Cheers!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.