How to completely reinstall CUPs/ reset all user config?

In the process of trying to get a new canon printer on my network, I managed to bork all of my printing abilities, including the ability to print from my old printer using USB. I believe that the easiest thing to do at this point would be to reinstall CUPS and reset all the cups-related user config files to default.

If I delete the cups folder in the root/etc directory, then reinstall cups, would those files get recreated with the defaults so I could start fresh? Is there a better way?

I am not quite a newbie to linux, but clearly I know just enough to get myself in trouble.

(In case you need to know, I am unable to get to cups using the localhost option, and any attempt to reach the printers using the GUI results in a “print service unavailable, bad file descripter” message.
the system log shows it reaches the printer, then a bunch of attempts to get CUPs started, ending in failure.
example: 9/7/20 9:21 AM systemd org.cups.cupsd.service: Failed with result ‘protocol’.)

Also I am using KDE with the latest update.

Thanks for your help in advance!

As long as noone else is trying to help - here is what I would do:

First, stop & disable the corresponding service

sudo systemctl disable --now org.cups.cupsd.service

Then remove manjaro-printer by

sudo pacman -Rsn manjaro-printer

Afterwards, check if cups is still installed by

pacman -Qi cups

If yes, then remove it as well by

sudo pacman -Rsn cups

You will still have config files left over, I would start to look for all files / folders within your hidden /home folders and delete anything linked to cups.

1 Like

Thanks, I’ll give that a try!

Thank you, your instructions were very clear.

I am having the problem that I am unable to delete related files in dolphin, even though I am logged in with admin privileges. I used to get a prompt for a password, but now any option for moving, deleting, renaming any root file is greyed out. Web searching led me to some old posts about how dolphin doesn’t let you do root, but those were three years ago. Surely this has been fixed and I’m just missing something? How do I get around this?

I tried skipping that step, but it seems that the problem is being caused by something in those root level config files in etc/cups., and dolphin wont let me touch them. (It’s giving me windows flashbacks!)

Edit: it appears editing root directories are impossible now in KDE? Since there appears no other way to delete/replace the cups config files that seem to be causing my problems, I am now in the process of backing up my personal files so I can reinstall all of Manjaro. Sigh. Thank you again for your help, though!

Use a terminal window and apply the “rm” command. If you are not familar with the syntax you can check the manual by “man rm”. If you combine it with sudo it’s usually deleting your targets. Be careful with “*" and "-r” option to avoid deleting files you actally want to keep. Best is to remove the files - file by file and not recursive (uunless there are too many files… :grin:)

Thanks, I saw this on the web abd tried it, but it kept telling me no such file or directory existed. I’ll try once more before giving up.

YAY that time it worked, I was able to remove the config files! I’d already started backing up my home files, though, so I think I will finish that and then try once again to reinstall Manjaro printer/cups. Thank you again for all of your help!

UPDATE: that did it! Thank you so much!!! Ive never been so happy to be back at square one. :upside_down_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.