How to change the value of $QT_QPA_PLATFORMTHEME?

How can I change the value of $QT_QPA_PLATFORMTHEME env variable from “qt5ct” to “gnome” ?

I have tried:

  • To edit .bashrc file and add the line
  • To create .profile file (it doesn’t exist by default)

But either of those do not work. Either does files are never sourced or something somewhere is resetting the value for it.

~/.bashrc is only sourced if you are effectively using bash as your shell. ~/.profile should be sourced too under those conditions, but it won’t be unless you add… :arrow_down:

source ~/.profile

… to ~/.bashrc or ~/.bash_profile. For some reason, that was not included in the default installation.

However, you are most likely using zsh as your shell, in which case the shell initialization file is ~/.zshrc. But even that won’t be the right place to put that command.

I cannot be sure because I don’t use GNOME, but it is possible that this variable is set from within /etc/environment or some other GUI-related configuration file, in which case there is of course a distinct difference between how X11 is started and how Wayland is started, depending on which of the two you use.

1 Like

Yes I do use zsh and yes you are correct it is set in /etc/environment.

By default should have nothing or close to nothing in it.
It is one of the handful of places to set a global environment variable … but its not GUI-specific or anything … maybe you were thinking of /etc/profile(.d)?

A file under /etc/profile.d/ would have been one of the possible locations, indeed, but /etc/environment was obviously where the variable was set on the OP’s machine. :man_shrugging:

Or in /etc/profile file itself … my point was environment is not one of the GUI-specific locations for global env vars, unlike profile.
Also OP asked “where to set it” not where the option pre-existed … I dont think manjaro (or many distros) ship with things in /etc/environment. Mine certainly only has what I put in there, otherwise it would only have the original comment in it.

We ship some defaults in GNOME’s /etc/environment, actually:

oh gnome. always gotta be special :sweat_smile:
(ok then … I guess gnome does … the others do not)



fine fine … but still

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.