How to change the desktop theme color?

Even though I've changed the theme of the desktop environment, I still have the Manjaro green showing up in a lot of places, particularly as an accent color when changing windows, hovering over things, in the login screen. I had this problem in XFCE, but chose to ignore it for since I was going to switch to another edition later since it wasn't intuitive, but now I have the same problem in Gnome.

Example images:


I don't use GNOME and I don't know how theming is done there, but those green accents are obviously part of a theme. There is also a difference between the application theme ─ which is what you see inside the application window ─ and the GNOME theme proper. So I reckon you'd need to change the GNOME theme.

Presumably GNOME has some "system settings" module, and then that would be where you set it. You can also download and install new themes from the GNOME store. :wink:

The easiest way would be to change to a different theme for the Gnome Shell. Open Tweaks > Appearance and in the option Shell select a theme that fits better to your desktop appearance.


Another way would be to find the relevant CSS rules for the theme's elements you want to change in the file /usr/share/themes/theme_name/gnome-shell/gnome-shell.css and overwrite them using the file ~/.config/gtk-3.0/gtk.css.
This approach will require some digging in the .css file and a lot of testing from your side.

1 Like

To my understanding Gnome themeing is mostly done through Gnome Tweaks, in which I set everything to the default theme already. That affected mostly the window borders. I also enabled the custom shells, and set it to default, but it's still green, although some settings that aren't default aren't green, and I don't believe that the default color of Gnome is Manjaro's green. Has the "default" theme been messed with in this case? Is there a way to get the original Gnome shell theme back?

The default in this case does most likely refer to the Manjaro-specific theming, not the upstream GNOME defaults. In Plasma for instance, the upstream default would be the Breeze theme, but in Manjaro's implementation, it is Breath.

In some cases, the upstream settings are often referred to as "vanilla", but I don't know whether you'll find any such name in your preferences ─ like I said, I don't use GNOME. The "default" will either way refer to Manjaro's own theming.

Well that's rather confusing then, since I believe the theme that was set by default was one of the Matcha themes.

Turns out that you don't need to mess around in the files at all. Manjaro Gnome ships with a package called manjaro-gnome-vanilla, which is found as a program called cleanup-manjar...(can't see the full name). Running it resets Gnome to seemingly its default look, removing all green accents.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by