How to change kernel config with buildarmpkg?

I’m having an odd issue configuring the linux-pinephone package while using buildarmpkg but I’m guessing I’m just doing something dumb and hopefully someone can clear it up. Whenever I uncomment one of the lines in this part of the script,

When the script gets to that point it pages through all the config options, only giving me the option to interactively choose the option on the last visible line in the terminal. It’s like the menu interface isn’t working and just printing eveything to the terminal at once. Any idea what I’m missing here?

As a result I can’t configure the kernel interactively.

If you uncomment make menuconfig and you run buildarmpkg in a terminal window if decent size, you should get a white/blue menu where you can select and de-select options.

Weird, that’s what I’m doing, in a fullscreen terminal. My laptop screen resolution isn’t that big though, 1366x768, that wouldn’t be the problem would it?

It shouldn’t be.

What is the output exactly?

That terminal is in the middle of building without changing the config so I don’t have a full log unfortunately, but the output looks like this,

* Temperature sensors
  Analog Devices Multi-Sensor Digital Temperature Measurement System (LTC2983) [N/m/y/?] 
  Maxim thermocouple sensors (MAXIM_THERMOCOUPLE) [N/m/y/?] 
  MLX90614 contact-less infrared sensor (MLX90614) [N/m/y/?] 
  MLX90632 contact-less infrared sensor with medical accuracy (MLX90632) [N/m/y/?] 
  TMP006 infrared thermopile sensor (TMP006) [N/m/y/?] 
  TMP007 infrared thermopile sensor with Integrated Math Engine (TMP007) [N/m/y/?] 
  TMP117 Digital temperature sensor with integrated NV memory (TMP117) [N/m/y/?] 
  Measurement Specialties TSYS01 temperature sensor using I2C bus connection (TSYS01) [N/m/y/?] 
  Measurement Specialties TSYS02D temperature sensor (TSYS02D) [N/m/y/?] 
  MAX31856 thermocouple sensor (MAX31856) [N/m/y/?] 
* Pulse-Width Modulation (PWM) Support
Pulse-Width Modulation (PWM) Support (PWM) [Y/n/?] 
  Atmel TC Block PWM support (PWM_ATMEL_TCB) [N/m/y/?] 
  ChromeOS EC PWM driver (PWM_CROS_EC) [N/m/y/?] 
  Freescale FlexTimer Module (FTM) PWM support (PWM_FSL_FTM) [N/m/y/?] 
  NXP PCA9685 PWM driver (PWM_PCA9685) [N/m/y/?] 
  Allwinner PWM support (PWM_SUN4I) [Y/n/m/?] 
* IRQ chip support
Amazon's Annapurna Labs Fabric Interrupt Controller (AL_FIC) [N/y/?]

So there’ll be a terminal sized page of that, and I can interactively select the last line/option on the page. One thing to note is that in the terminal session the default choices are printed, but it’s not preserved in scrollback.

hm. Try commenting out make prepare above the make menuconfig.

It might already be using the config at the make prepare step.

Yep thanks, that has let me access the menu. But will I get a successful build with make prepare commented out? I only ask because building takes me about eight hours :wink:

There are some other build errors I can’t figure out, I’ll start a separate thread for those.

Probably not. Our PKGBUILD has a couple of options. A bit further down there’s a couple of lines you can uncomment out to stop the building, so you can copy out the new config and place it instead of the old config. Then when that’s done, you uncomment make prepare and commit the other stuff out again. Run updpkgsums and then build it again.

1 Like

Tip: When pasting terminal output on Discourse forums, one can either…

  • Use the Preformatted text </> toolbar button–NOT the Quote " button.

  • Add three backticks ` above and below the text (Markdown):

    type or paste code here

  • Use HTML:

    type or paste code here

I’ve done it for you this time. :wink:

How to is not a question. I’ve added proper punctuation.

Wanted to follow up that I built the package and point out a couple of perhaps obvious things to help future beginners like myself.

The new .config is saved in the package tree’s ./src/linux... directory (created after you run buildarmpkg the first time following Strit’s instructions above to comment out make prepare and uncomment the appropriate config lines – I’m assuming this procedure is specific to this linux-pinephone package). Copy this file over the config in the package’s root directory. Then before you buildarmpkg again, delete that ./src/linux... directory otherwise the build will error out.

That was one step that puzzled me actually, I’m not sure if I did it correctly, but the build finished successfully.

Also installing Manjaro on a more powerful PC really helps the build time :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.