How to change "either VNC or SSHD" to "VNC and SSHD"

The first “status” of my Raspi4 after installation was, that there was a working connection via ssh/d.
Then I additionally (that is: I didn’t touch the ssh settings) installed x11vnc, which works now.
When booted, only the port for the vnc-connection is open (checked with nmap on my Gentoo-PC).
After I logged in via vnc, ssh is also available.
In case of not being able to connect via vnc, I am locked out with this configuration.

How can I enable sshd regardless of the status of vnc (being connected/opened/started/crashed or whatever…) ?

I never had a raspi but it seems that sshd was started and running, but not enabled.
After reboot it is not started - and thus you can’t use it to connect.

systemctl status sshd

if it isn’t running, which seems to be the case:

systemctl start sshd

enable it, so it will be started when the machine boots:

systemctl enable sshd

A while ago I created a serie of topics on SSH and VNC for Manjaro and the last one specifically for Raspberry Pi.

  1. [root tip] Set up your own SSH service
  2. [root tip] TigerVNC over SSH
  3. [root tip] Install Raspberry Pi - VNC over SSH

As @Nachlese said - you need to enable the service to be able use it after reboots.

Without knowledge on excatly which Manjaro you installed on your PI - I know that at least the miniminal edition comes with ssh enabled since it is designed to be headless and thus only accessible using ssh.