How to change default terminal environment varible in Manjaro?

How can I change my default terminal env variable in manjaro linux. echo $TERM gives xterm-256 as output. And when I open htop or ranger from app drawer it is opening up in xterm. I want to change it to alacritty. How can I do that?

Edit: I am so sorry everyone. The echo $TERM actually returns my current terminal, and I guess alacritty is some modified xterm itself and that is why it is showing xterm. But anyway, I can’t open htop or other cli programs directly from the app drawer when I uninstalled xterm. What can I do about that?

for one, we can copy .desktop (if exists) in home and change Exec= : add env parameter
or load from terminal

TERM=xterm-mono /usr/bin/my_program
TERM=xterm-mono  htop

for all, can change .bashrc or .zshrc

Good reading.